CVE-2026-44228 RT: Stored Cross-Site Scripting via insufficient template escaping

Medium 5.4 Published Updated

An authenticated user can inject JavaScript into RT, leading to code execution or account takeover when other users view the affected page.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-44228?

CVE-2026-44228 is a medium-severity cross-site scripting vulnerability in bestpractical rt, published on 20 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

RT is an open source, enterprise-grade issue and ticket tracking system. Versions 6.0.0 and above, prior to 6.0.3, contain a stored Cross-Site Scripting (XSS) vulnerability, where user-controlled data is rendered without proper HTML escaping. An authenticated user with permission to set the relevant data can inject JavaScript that executes when another RT user views the affected page. This issue has been fixed in version 6.0.3.

Weakness: CWE-79

Which versions are affected by CVE-2026-44228?

It affects 1 product.

Products include Bestpractical Request Tracker.

How do I fix CVE-2026-44228?

No fix has been published for CVE-2026-44228 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-44228 being exploited?

There is no known exploitation of CVE-2026-44228 in the wild and no public exploit code.

Sources

Also known as GHSA-pfgp-5j8g-phgc, UBUNTU-CVE-2026-44228.

Is CVE-2026-44228 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free