{"answers":{"affected":"1 open source package ship an affected version, including rabbitmq-c.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44235 exists.","fix":"Upgrade rabbitmq-c to 0.16.0 or later.","what":"CVE-2026-44235 is a medium-severity vulnerability in alanxz rabbitmq-c, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-44235 and fix it if it is affected.\n\nWhat it is: CVE-2026-44235 is a medium-severity vulnerability in alanxz rabbitmq-c, published on 17 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44235 exists.\n\nAffected packages and fixed versions:\n- rabbitmq-c (Bitnami): affected all versions; fixed in 0.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44235/ (Markdown: https://insights.sbomify.com/CVE-2026-44235/index.md)","id":"CVE-2026-44235","markdown":"https://insights.sbomify.com/CVE-2026-44235/index.md","name":"CVE-2026-44235","record":{"aliases":["AZL-105084","BIT-rabbitmq-c-2026-44235","DEBIAN-CVE-2026-44235","ECHO-0351-ee63-bf06","GHSA-9mmv-r8g3-qp46","UBUNTU-CVE-2026-44235"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"AMQP client library","requires_auth":"none","summary":"A malicious AMQP server can trigger an integer underflow in rabbitmq-c, causing an out-of-bounds read and application crash.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"},{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"rabbitmq-c is a C-language AMQP client library for RabbitMQ. Prior to 0.16.0, a malicious AMQP server can send an undersized HEADER or METHOD frame during client login and cause unsigned size_t underflow in amqp_handle_input() in librabbitmq/amqp_connection.c. The parser subtracts HEADER_SIZE, fixed per-frame fields, and FOOTER_SIZE from state-\u003etarget_size without first checking the minimum frame length. The wrapped encoded.len value is passed through amqp_decode_properties() to amqp_decode_table_internal(), where it defeats bounds checks and causes an out-of-bounds read and process crash. An on-path attacker can also trigger the issue when AMQP traffic is not protected by TLS with certificate validation. The demonstrated impact is denial of service, with no reliable memory disclosure or code execution shown. This issue is fixed in version 0.16.0.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"rabbitmq-c: size_t underflow in AMQP frame length computation leads to out-of-bounds read","id":"CVE-2026-44235","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"rabbitmq-c: Heap buffer overflow in AMQP login handshake via undersized connection.tune.frame_max","id":"CVE-2026-44236"},"packages":[{"ecosystem":"Bitnami","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"rabbitmq-c","purl":"pkg:bitnami/rabbitmq-c","source":"BIT-rabbitmq-c-2026-44235"}],"prev":{"headline":"dssrf: every IPv6 category bypasses is_url_safe","id":"CVE-2026-44232"},"products":["rabbitmq-c"],"published":"2026-09-17","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-17","vendors":["alanxz"]},"summary":"A malicious AMQP server can trigger an integer underflow in rabbitmq-c, causing an out-of-bounds read and application crash.","url":"https://insights.sbomify.com/CVE-2026-44235/"}