# CVE-2026-44240: basic-ftp allows a malicious FTP server to cause client-side denial of service via unbounded multiline control response buffering

> A malicious FTP server can cause client-side denial of service in basic-ftp by sending unbounded multiline responses, leading to resource exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 14 May 2026
- **Also known as:** CLEANSTART-2026-DY27694, CLEANSTART-2026-NF21884, CLSA-2026-1780879904, DEBIAN-CVE-2026-44240, ECHO-88de-b7ea-e064, GHSA-rpmf-866q-6p89, MINI-5738-cp3p-mpcc, MINI-59mg-5x93-xvjr, MINI-827c-98m4-6xqh, MINI-8whg-w956-xcwf, MINI-cv63-9hrr-jhpw, MINI-f2gj-49jr-9754, MINI-f558-w933-8vhr, MINI-f75h-r6x5-8vr6, MINI-f78v-769v-6fp7, MINI-g945-v33g-4gv9, MINI-h4c9-j62q-6756, MINI-h547-jmcw-qcw8, MINI-h9x2-83hv-vffj, MINI-jqqp-chr5-77vj, MINI-m4wc-rhf3-qj73, MINI-m532-98xg-pvmh, MINI-m77h-rxrm-8cx2, MINI-qrcf-prch-6x58, MINI-r3pw-c9qm-g4vp, MINI-w596-3hm4-5g3r, MINI-w9g7-mw9w-47jp, MINI-wxm6-694w-6xwg, MINI-x2mm-gwc5-6h9p, MINI-x697-gh93-p8cj, ROOT-APP-NPM-CVE-2026-44240, UBUNTU-CVE-2026-44240

## What is CVE-2026-44240?

CVE-2026-44240 is a high-severity denial of service vulnerability in patrickjuchli basic-ftp, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

basic-ftp is an FTP client for Node.js. Prior to 5.3.1, basic-ftp is vulnerable to client-side denial of service when parsing FTP control-channel multiline responses. A malicious or compromised FTP server can send an unterminated multiline response during the initial FTP banner phase, before authentication. The client keeps appending attacker-controlled data into FtpContext._partialResponse and repeatedly reparses the accumulated buffer without enforcing a maximum control response size. As a result, an application using basic-ftp can remain stuck in connect() while memory and CPU usage grow under attacker-controlled input. This can lead to process-level denial of service, container OOM kills, worker restarts, queue backlog, or service degradation in applications that automatically connect to FTP endpoints. This vulnerability is fixed in 5.3.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-44240?

2 open source packages ship an affected version, including basic-ftp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `basic-ftp` | npm | All versions | 5.3.1 |
| `basic-ftp` | npm | All versions | 5.3.1 |

## How do I fix CVE-2026-44240?

Upgrade basic-ftp to 5.3.1 or later.

## Is CVE-2026-44240 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44240 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44240 and fix it if it is affected.

What it is: CVE-2026-44240 is a high-severity denial of service vulnerability in patrickjuchli basic-ftp, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44240 exists.

Affected packages and fixed versions:
- basic-ftp (npm): affected all versions; fixed in 5.3.1
- basic-ftp (npm): affected all versions; fixed in 5.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44240/ (Markdown: https://insights.sbomify.com/CVE-2026-44240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44240
- OSV: https://osv.dev/vulnerability/CVE-2026-44240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44240/
Summaries are generated and may contain mistakes; the official description above is the record.
