# CVE-2026-44244: GitPython: Newline injection in config_writer().set_value() enables RCE via core.hooksPath

> Attackers can inject newlines into Git config values to set core.hooksPath, leading to remote code execution when Git hooks are triggered.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 9 May 2026
- **Also known as:** CLSA-2026-1784077474, DEBIAN-CVE-2026-44244, ECHO-75d1-905c-5401, GHSA-v87r-6q3f-2j67, MINI-frg6-4pwp-f3xw, MINI-hv35-79fw-5cwj, PYSEC-2026-2163, ROOT-APP-PYPI-CVE-2026-44244, UBUNTU-CVE-2026-44244

## What is CVE-2026-44244?

CVE-2026-44244 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

GitPython is a python library used to interact with Git repositories. Prior to version 3.1.49, GitConfigParser.set_value() passes values to Python's configparser without validating for newlines. GitPython's own _write() converts embedded newlines into indented continuation lines (e.g. \n becomes \n\t), but Git still accepts an indented [core] stanza as a section header — so the injected core.hooksPath becomes effective configuration. Any Git operation that invokes hooks (commit, merge, checkout) will then execute scripts from the attacker-controlled path. This issue has been patched in version 3.1.49.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-44244?

3 open source packages ship an affected version, including gitpython and GitPython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitpython` | PyPI | All versions | 3.1.49 |
| `gitpython` | PyPI | All versions | 3.1.49 |
| `GitPython` | PyPI | All versions | 3.1.49 |

Products: Gitpython Project Gitpython.

## How do I fix CVE-2026-44244?

Upgrade gitpython to 3.1.49 or later.

## Is CVE-2026-44244 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44244 exists.

## Other vulnerabilities in gitpython-developers GitPython

- [CVE-2023-40267](https://insights.sbomify.com/CVE-2023-40267/): GitPython vulnerable to remote code execution due to insufficient sanitization of input arguments (critical 9.8)
- [CVE-2026-78676](https://insights.sbomify.com/CVE-2026-78676/): GitPython before 3.1.59 Remote Code Execution via Config Injection (critical 9.3)
- [CVE-2026-67324](https://insights.sbomify.com/CVE-2026-67324/): GitPython 3.1.50 Authentication Bypass via Joined Short Options (critical 9.3)
- [CVE-2026-42215](https://insights.sbomify.com/CVE-2026-42215/): GitPython: Command injection via Git options bypass (high 8.8)
- [CVE-2026-87817](https://insights.sbomify.com/CVE-2026-87817/): GitPython before 3.1.60 Remote Code Execution via Git Directory Impersonation (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44244 and fix it if it is affected.

What it is: CVE-2026-44244 is a high-severity code injection vulnerability in gitpython-developers GitPython, published on 7 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44244 exists.

Affected packages and fixed versions:
- gitpython (PyPI): affected all versions; fixed in 3.1.49
- gitpython (PyPI): affected all versions; fixed in 3.1.49
- GitPython (PyPI): affected all versions; fixed in 3.1.49

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44244/ (Markdown: https://insights.sbomify.com/CVE-2026-44244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44244
- OSV: https://osv.dev/vulnerability/CVE-2026-44244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44244/
Summaries are generated and may contain mistakes; the official description above is the record.
