CVE-2026-44247 Volcano: Webhook server vulnerable to OOM due to unbounded HTTP request body size
An attacker with in-cluster access can crash the Volcano webhook server by sending oversized HTTP requests, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44247?
CVE-2026-44247 is a medium-severity denial of service vulnerability in volcano-sh volcano, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Volcano is a Kubernetes-native batch scheduling system. Prior to v1.14.2, v1.13.3, and v1.12.4, the Volcano webhook server does not enforce a size limit on incoming HTTP request bodies. Any in-cluster pod that can reach the webhook endpoint may send an arbitrarily large request body, potentially causing the webhook server to be killed by OOM. All Volcano deployments with the webhook server exposed to in-cluster traffic are affected. This vulnerability is fixed in v1.14.2, v1.13.3, and v1.12.4.
Which versions are affected by CVE-2026-44247?
7 open source packages ship an affected version, including volcano.sh/volcano. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
volcano.sh/volcano Go | All versions | 1.12.4, 1.13.3, 1.14.2 |
volcano.sh/volcano Go | All versions | 1.12.4 |
volcano.sh/volcano Go | All versions | 1.12.4 |
volcano.sh/volcano Go | From 1.13.0 | 1.13.3 |
volcano.sh/volcano Go | From 1.13.0 | 1.13.3 |
volcano.sh/volcano Go | From 1.14.0 | 1.14.2 |
1 more packages
volcano.sh/volcano Go | From 1.14.0 | 1.14.2 |
Products include Linuxfoundation Volcano.
How do I fix CVE-2026-44247?
Upgrade volcano.sh/volcano to a fixed version for your release line: 1.12.4, 1.13.3 or 1.14.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-44247 being exploited?
There is no known exploitation of CVE-2026-44247 in the wild and no public exploit code.
Sources
Also known as GHSA-8wxp-xxp2-rcgx, GO-2026-5269.