CVE-2026-44248 Netty: Resource exhaustion in MqttDecoder
Attackers can cause resource exhaustion in Netty MQTT applications by sending oversized property headers, leading to denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44248?
CVE-2026-44248 is a medium-severity denial of service vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, the MQTT 5 header Properties section is parsed and buffered before any message size limit is applied. Specifically, in MqttDecoder, the decodeVariableHeader() method is called before the bytesRemainingBeforeVariableHeader > maxBytesInMessage check. The decodeVariableHeader() can call other methods which will call decodeProperties(). Effectively, Netty does not apply any limits to the size of the properties being decoded. Additionally, because MqttDecoder extends ReplayingDecoder, Netty will repeatedly re-parse the enormous Properties sections and buffer the bytes in memory, until the entire thing parses to completion. This can cause high resource usage in both CPU and memory. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.
Which versions are affected by CVE-2026-44248?
4 open source packages ship an affected version, including io.netty:netty-codec-mqtt. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
io.netty:netty-codec-mqtt Maven | All versions | 4.1.133.Final |
io.netty:netty-codec-mqtt Maven | All versions | 4.1.133.Final |
io.netty:netty-codec-mqtt Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
io.netty:netty-codec-mqtt Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
Products include Netty Netty.
How do I fix CVE-2026-44248?
Upgrade io.netty:netty-codec-mqtt to a fixed version for your release line: 4.1.133.Final or 4.2.13.Final.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-44248 being exploited?
There is no known exploitation of CVE-2026-44248 in the wild and no public exploit code.
Other vulnerabilities in Netty Netty
- CVE-2026-75595 Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext
- CVE-2026-75596 Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing
- CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
- CVE-2026-55851 Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion
- CVE-2026-56745 Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion
Sources
Also known as CLEANSTART-2026-DB30456, CLEANSTART-2026-KV24207, CLEANSTART-2026-VC18783, DEBIAN-CVE-2026-44248, GHSA-jfg9-48mv-9qgx, MINI-85vc-vjxc-rmx8 and 7 more.