# CVE-2026-44248: Netty: Resource exhaustion in MqttDecoder

> Attackers can cause resource exhaustion in Netty MQTT applications by sending oversized property headers, leading to denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 11 Sep 2026
- **Also known as:** CLEANSTART-2026-DB30456, CLEANSTART-2026-KV24207, CLEANSTART-2026-VC18783, DEBIAN-CVE-2026-44248, GHSA-jfg9-48mv-9qgx, MINI-85vc-vjxc-rmx8, MINI-8qc4-m9g5-677g, MINI-gx2m-mw48-j4rx, MINI-hgqc-qcjj-jxgg, MINI-j6hp-cv3p-9349, MINI-mx3x-pj44-93xj, MINI-q9j3-3g64-qhwj, RHLW-2026-48b9709ba25473be

## What is CVE-2026-44248?

CVE-2026-44248 is a medium-severity denial of service vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is an asynchronous, event-driven network application framework. Prior to 4.2.13.Final and 4.1.133.Final, the MQTT 5 header Properties section is parsed and buffered before any message size limit is applied. Specifically, in MqttDecoder, the decodeVariableHeader() method is called before the bytesRemainingBeforeVariableHeader > maxBytesInMessage check. The decodeVariableHeader() can call other methods which will call decodeProperties(). Effectively, Netty does not apply any limits to the size of the properties being decoded. Additionally, because MqttDecoder extends ReplayingDecoder, Netty will repeatedly re-parse the enormous Properties sections and buffer the bytes in memory, until the entire thing parses to completion. This can cause high resource usage in both CPU and memory. This vulnerability is fixed in 4.2.13.Final and 4.1.133.Final.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-44248?

4 open source packages ship an affected version, including io.netty:netty-codec-mqtt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-mqtt` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-codec-mqtt` | Maven | All versions | 4.1.133.Final |
| `io.netty:netty-codec-mqtt` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |
| `io.netty:netty-codec-mqtt` | Maven | From 4.2.0.Alpha1 | 4.2.13.Final |

Products: Netty Netty.

## How do I fix CVE-2026-44248?

Upgrade io.netty:netty-codec-mqtt to a fixed version for your release line: 4.1.133.Final or 4.2.13.Final.

## Is CVE-2026-44248 being exploited?

There is no known exploitation of CVE-2026-44248 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44248 and fix it if it is affected.

What it is: CVE-2026-44248 is a medium-severity denial of service vulnerability in Netty Netty, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44248 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-mqtt (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-codec-mqtt (Maven): affected all versions; fixed in 4.1.133.Final
- io.netty:netty-codec-mqtt (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final
- io.netty:netty-codec-mqtt (Maven): affected from 4.2.0.Alpha1; fixed in 4.2.13.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44248/ (Markdown: https://insights.sbomify.com/CVE-2026-44248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44248
- OSV: https://osv.dev/vulnerability/CVE-2026-44248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44248/
Summaries are generated and may contain mistakes; the official description above is the record.
