# CVE-2026-44250: Netty: Memory Exhaustion in RedisArrayAggregator due to Deeply Nested Arrays

> Attackers can cause denial of service in Netty Redis servers by sending deeply nested arrays, leading to memory exhaustion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 18 Sep 2026
- **Also known as:** CLEANSTART-2026-CG75850, CLEANSTART-2026-GH03249, CLEANSTART-2026-WG67624, DEBIAN-CVE-2026-44250, GHSA-3244-j874-rhc2, MINI-4w89-7rf4-3pm6, MINI-7vh4-qq6f-8gf5, MINI-crpf-vv9m-jqjc, MINI-jrcm-ghch-qqg3, MINI-mhq9-3mgg-f2xj, MINI-p6f8-42vc-f3j4, MINI-qp6r-r3g6-qr9r, MINI-v6pw-m7x8-vjcv, MINI-xm2p-p4ww-c5jg, UBUNTU-CVE-2026-44250

## What is CVE-2026-44250?

CVE-2026-44250 is a high-severity denial of service vulnerability in Netty Netty, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. In netty-codec-redis prior to versions 4.1.135.Final and 4.2.15.Final, an attacker can cause DoS by sending a crafted Redis payload with deeply nested arrays. This forces the server to allocate a massive number of state objects and collections, leading to memory exhaustion and an OutOfMemoryError. Versions 4.1.135.Final and 4.2.15.Final patch the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-44250?

4 open source packages ship an affected version, including io.netty:netty-codec-redis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-redis` | Maven | All versions | 4.1.135.Final |
| `io.netty:netty-codec-redis` | Maven | All versions | 4.1.135.Final |
| `io.netty:netty-codec-redis` | Maven | From 4.2.0.Final | 4.2.15.Final |
| `io.netty:netty-codec-redis` | Maven | From 4.2.0.Final | 4.2.15.Final |

Products: Netty Netty.

## How do I fix CVE-2026-44250?

Upgrade io.netty:netty-codec-redis to a fixed version for your release line: 4.1.135.Final or 4.2.15.Final.

## Is CVE-2026-44250 being exploited?

There is no known exploitation of CVE-2026-44250 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44250 and fix it if it is affected.

What it is: CVE-2026-44250 is a high-severity denial of service vulnerability in Netty Netty, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44250 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-redis (Maven): affected all versions; fixed in 4.1.135.Final
- io.netty:netty-codec-redis (Maven): affected all versions; fixed in 4.1.135.Final
- io.netty:netty-codec-redis (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final
- io.netty:netty-codec-redis (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44250/ (Markdown: https://insights.sbomify.com/CVE-2026-44250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44250
- OSV: https://osv.dev/vulnerability/CVE-2026-44250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44250/
Summaries are generated and may contain mistakes; the official description above is the record.
