# CVE-2026-44260: efw4.X: readonly Flag Not Enforced Server-Side

> Attackers can bypass server-side readonly restrictions in efw4.X to perform unauthorized file modifications by sending direct requests, ignoring client-side UI controls.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** GHSA-5454-qhrf-vcvh

## What is CVE-2026-44260?

CVE-2026-44260 is a high-severity missing authorization vulnerability in efwGrp efw4.X, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

efw4.X is an Enterprise Framework for Web. Prior to 4.08.010, the readonly flag set on the <efw:elFinder> JSP tag is intended to prevent file modifications. When protected=true, elfinder_checkRisk enforces that the client sends readonly=true (matching the session value), but no event handler checks the readonly value before performing write operations. The flag only controls client-side UI elements (disabling buttons) and response metadata (write: 0, locked: 1). An attacker who sends requests directly (bypassing the UI) can perform all file operations despite readonly=true. This vulnerability is fixed in 4.08.010.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-44260?


## How do I fix CVE-2026-44260?

No fix has been published for CVE-2026-44260 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44260 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44260 and fix it if it is affected.

What it is: CVE-2026-44260 is a high-severity missing authorization vulnerability in efwGrp efw4.X, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44260 exists.

Affected product: efwGrp efw4.X. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44260/ (Markdown: https://insights.sbomify.com/CVE-2026-44260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44260
- OSV: https://osv.dev/vulnerability/CVE-2026-44260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44260/
Summaries are generated and may contain mistakes; the official description above is the record.
