# CVE-2026-44264: Weblate is vulnerable to XSS via crafted Markdown

> Attackers can inject malicious scripts via crafted Markdown in user comments, potentially leading to session hijacking or code execution.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-5cmv-3rc4-7279, PYSEC-2026-2319

## What is CVE-2026-44264?

CVE-2026-44264 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weblate is a web based localization tool. Prior to version 5.17.1, the Markdown renderer used in user comments and other user-provided content didn't properly sanitize some attributes. This issue has been patched in version 5.17.1.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-44264?

3 open source packages ship an affected version, including weblate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `weblate` | PyPI | All versions | 5.17.1 |
| `weblate` | PyPI | All versions | 5.17.1 |
| `weblate` | PyPI | All versions | 5.17.1 |

Products: Weblate Weblate.

## How do I fix CVE-2026-44264?

Upgrade weblate to 5.17.1 or later.

## Is CVE-2026-44264 being exploited?

There is no known exploitation of CVE-2026-44264 in the wild and no public exploit code.

## Other vulnerabilities in WeblateOrg weblate

- [CVE-2025-68398](https://insights.sbomify.com/CVE-2025-68398/): Weblate has git config file overwrite vulnerability that leads to remote code execution (critical 9.1)
- [CVE-2026-34393](https://insights.sbomify.com/CVE-2026-34393/): Weblate: Privilege escalation in the user API endpoint (high 8.8)
- [CVE-2026-33435](https://insights.sbomify.com/CVE-2026-33435/): Weblate: Remote code execution during backup restoration (high 8.1)
- [CVE-2026-34242](https://insights.sbomify.com/CVE-2026-34242/): Weblate: Arbitrary File Read via Symlink (high 7.7)
- [CVE-2025-68279](https://insights.sbomify.com/CVE-2025-68279/): Weblate has an arbitrary file read via symbolic links (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44264 and fix it if it is affected.

What it is: CVE-2026-44264 is a medium-severity cross-site scripting vulnerability in WeblateOrg weblate, published on 7 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44264 in the wild and no public exploit code.

Affected packages and fixed versions:
- weblate (PyPI): affected all versions; fixed in 5.17.1
- weblate (PyPI): affected all versions; fixed in 5.17.1
- weblate (PyPI): affected all versions; fixed in 5.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44264/ (Markdown: https://insights.sbomify.com/CVE-2026-44264/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44264
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44264
- OSV: https://osv.dev/vulnerability/CVE-2026-44264

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44264/
Summaries are generated and may contain mistakes; the official description above is the record.
