{"answers":{"affected":"6 open source packages ship an affected version, including aws-lc-fips-sys and aws-lc-sys.","exploited":"There is no known exploitation of CVE-2026-4428 in the wild and no public exploit code.","fix":"Upgrade aws-lc-fips-sys to 0.13.13 or later.","what":"CVE-2026-4428 is a critical vulnerability in AWS-LC, published on 19 Mar 2026."},"fix_prompt":"Check this codebase for CVE-2026-4428 and fix it if it is affected.\n\nWhat it is: CVE-2026-4428 is a critical vulnerability in AWS-LC, published on 19 Mar 2026. \nExploitation: There is no known exploitation of CVE-2026-4428 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aws-lc-fips-sys (crates.io): affected from 0.13.0; fixed in 0.13.13\n- aws-lc-fips-sys (crates.io): affected from 0.13.0; fixed in 0.13.13\n- aws-lc-fips-sys (crates.io): affected from 0.13.0; fixed in 0.13.13\n- aws-lc-sys (crates.io): affected from 0.15.0; fixed in 0.39.0\n- aws-lc-sys (crates.io): affected from 0.15.0; fixed in 0.39.0\n- aws-lc-sys (crates.io): affected from 0.15.0; fixed in 0.39.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-4428/ (Markdown: https://insights.sbomify.com/CVE-2026-4428/index.md)","id":"CVE-2026-4428","markdown":"https://insights.sbomify.com/CVE-2026-4428/index.md","name":"CVE-2026-4428","record":{"aliases":["CLEANSTART-2026-CP29339","CLEANSTART-2026-KO91449","GHSA-9f94-5g5w-gf6r","MINI-2mxc-x544-36px","MINI-37cj-564v-w58g","MINI-3rr3-crv7-vp34","MINI-44gw-qc47-wxcv","MINI-64r5-3q5q-wf4x","MINI-8f4q-7932-6266","MINI-9fq2-92cx-vqp3","MINI-9v2h-mrvw-hrhw","MINI-c3r8-48mx-hqwh","MINI-gxc6-2v9p-8fq3","MINI-h4mm-mwv8-6f74","MINI-jmpw-pxhg-rqc9","MINI-m6jc-4qmj-c6x2","MINI-m95r-25pq-7rgw","MINI-p5p4-5x63-5w97","MINI-qj8f-27fx-mww6","RUSTSEC-2026-0042","RUSTSEC-2026-0048"],"analysis":null,"analysis_generated_by":null,"assigner":"AMZN","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-299","name":"Improper Check for Certificate Revocation"}],"description":"A logic error in CRL distribution point validation in AWS-LC before 1.71.0 causes partitioned CRLs to be incorrectly rejected as out of scope, which allows  a revoked certificate to bypass certificate revocation checks.\n\nTo remediate this issue, users should upgrade to AWS-LC 1.71.0 or AWS-LC-FIPS-3.3.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CRL Distribution Point Scope Check Logic Error in AWS-LC","id":"CVE-2026-4428","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":null,"year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"OSM \u003c= 6.1.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'marker_name' Shortcode Attribute","id":"CVE-2026-4429"},"packages":[{"ecosystem":"crates.io","fixed":["0.13.13"],"introduced":["0.13.0"],"last_affected":[],"package":"aws-lc-fips-sys","purl":null,"source":"GHSA-9f94-5g5w-gf6r"},{"ecosystem":"crates.io","fixed":["0.13.13"],"introduced":["0.13.0"],"last_affected":[],"package":"aws-lc-fips-sys","purl":"pkg:cargo/aws-lc-fips-sys","source":"GHSA-9f94-5g5w-gf6r"},{"ecosystem":"crates.io","fixed":["0.13.13"],"introduced":["0.13.0"],"last_affected":[],"package":"aws-lc-fips-sys","purl":"pkg:cargo/aws-lc-fips-sys","source":"RUSTSEC-2026-0042"},{"ecosystem":"crates.io","fixed":["0.39.0"],"introduced":["0.15.0"],"last_affected":[],"package":"aws-lc-sys","purl":null,"source":"GHSA-9f94-5g5w-gf6r"},{"ecosystem":"crates.io","fixed":["0.39.0"],"introduced":["0.15.0"],"last_affected":[],"package":"aws-lc-sys","purl":"pkg:cargo/aws-lc-sys","source":"GHSA-9f94-5g5w-gf6r"},{"ecosystem":"crates.io","fixed":["0.39.0"],"introduced":["0.15.0"],"last_affected":[],"package":"aws-lc-sys","purl":"pkg:cargo/aws-lc-sys","source":"RUSTSEC-2026-0048"}],"prev":{"headline":"Libarchive: libarchive: denial of service via malformed iso file processing","id":"CVE-2026-4426"},"products":["AWS-LC","AWS-LC-FIPS"],"published":"2026-03-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-25","vendors":["AWS"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-4428/"}