# CVE-2026-44282: Election question titles allow stored script execution

> Low-privilege administrators can inject scripts into election question titles, leading to stored XSS execution in visitors' browsers.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-9mvp-w4rr-5c6x

## What is CVE-2026-44282?

CVE-2026-44282 is a medium-severity cross-site scripting vulnerability in decidim, published on 15 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Decidim is a participatory democracy framework. Prior to 0.32.0, a low-privilege process-scoped administrator or election editor with question-management rights can store HTML or script-bearing content in question.body. The question_title helper returns the translatable question body through html_safe without a sanitization boundary, causing stored script execution when visitors open public election pages or voting booth screens. The persisted script executes in visitors' browsers. The vulnerability is fixed in 0.32.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44282?

2 open source packages ship an affected version, including decidim-elections.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `decidim-elections` | RubyGems | All versions | 0.32.0 |
| `decidim-elections` | RubyGems | All versions | 0.32.0 |

## How do I fix CVE-2026-44282?

Upgrade decidim-elections to 0.32.0 or later.

## Is CVE-2026-44282 being exploited?

There is no known exploitation of CVE-2026-44282 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44282 and fix it if it is affected.

What it is: CVE-2026-44282 is a medium-severity cross-site scripting vulnerability in decidim, published on 15 Sep 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44282 in the wild and no public exploit code.

Affected packages and fixed versions:
- decidim-elections (RubyGems): affected all versions; fixed in 0.32.0
- decidim-elections (RubyGems): affected all versions; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44282/ (Markdown: https://insights.sbomify.com/CVE-2026-44282/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44282
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44282
- OSV: https://osv.dev/vulnerability/CVE-2026-44282

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44282/
Summaries are generated and may contain mistakes; the official description above is the record.
