# CVE-2026-44283: etcd: Read access via PrevKv in etcd transactions may bypass RBAC authorization checks

> Authenticated users can bypass RBAC checks to read unauthorized data or attach leases via etcd transaction operations.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 16 May 2026
- **Also known as:** AZL-86898, BELL-CVE-2026-44283, BIT-etcd-2026-44283, DEBIAN-CVE-2026-44283, ECHO-62a3-49c9-6673, GHSA-x35m-3gp4-4fh5, GO-2026-5736, MINI-4x7p-8vc8-fvg7, MINI-59px-63fv-qqgh, MINI-6936-hxrh-4857, MINI-79hr-whj5-mwgr, MINI-8hcm-w55c-wjp4, MINI-cv23-4xgr-8xcc, MINI-fqjm-qx9h-87r3, MINI-fxpx-gc2p-ggrm, MINI-gjxx-8vf4-gv7v, MINI-gqq8-5827-v3r8, MINI-hj7p-9q8x-6qcg, MINI-hjf7-53cm-33cr, MINI-j3jc-g7w6-fff3, MINI-mwr2-r393-7378, MINI-qrgg-5wj3-m3px, MINI-r2h4-ffrc-pj8x, MINI-vwv4-hvqx-4825, MINI-w7fx-79jg-gwrc, MINI-wx27-6mxf-4hhc, MINI-x4pq-2x92-85vx, MINI-xqch-vvv5-j8h7, UBUNTU-CVE-2026-44283, openSUSE-SU-2026:10980-1

## What is CVE-2026-44283?

CVE-2026-44283 is a missing authorization vulnerability in etcd-io etcd, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

etcd is a distributed key-value store for the data of a distributed system. Prior to 3.4.44, 3.5.30, and 3.6.11, a vulnerability in etcd allows read access via PrevKv, or lease attachment in Put requests within transaction operations, to bypass RBAC authorization checks. An authenticated user without sufficient read or lease-related permissions may be able to access unauthorized data or attach leases by invoking transaction operations with these features enabled. This vulnerability is fixed in 3.4.44, 3.5.30, and 3.6.11.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-44283?

8 open source packages ship an affected version, including go.etcd.io/etcd/v3, etcd and go.etcd.io/etcd. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.etcd.io/etcd/v3` | Go | From 3.5.0 | 3.5.30 |
| `go.etcd.io/etcd/v3` | Go | From 3.5.0 | 3.5.30 |
| `go.etcd.io/etcd/v3` | Go | From 3.6.0 | 3.6.11 |
| `go.etcd.io/etcd/v3` | Go | From 3.6.0 | 3.6.11 |
| `etcd` | Bitnami | All versions | 3.4.44, 3.5.30, 3.6.11 |
| `go.etcd.io/etcd` | Go | All versions | 3.4.44 |
| `go.etcd.io/etcd` | Go | All versions | 3.4.44 |
| `go.etcd.io/etcd/server/v3` | Go | From 3.5.0 | 3.5.30, 3.6.11 |
| `flannel` | openSUSE:Tumbleweed | All versions | 0.28.5-1.1 |

Products: Etcd Etcd.

## How do I fix CVE-2026-44283?

Upgrade go.etcd.io/etcd/v3 to a fixed version for your release line: 3.5.30 or 3.6.11.

## Is CVE-2026-44283 being exploited?

There is no known exploitation of CVE-2026-44283 in the wild and no public exploit code.

## Other vulnerabilities in etcd-io etcd

- [CVE-2021-28235](https://insights.sbomify.com/CVE-2021-28235/): Etcd-io Improper Authentication vulnerability (critical 9.8)
- [CVE-2026-33413](https://insights.sbomify.com/CVE-2026-33413/): etcd: Authorization bypasses in multiple APIs (high 8.8)
- [CVE-2022-34038](https://insights.sbomify.com/CVE-2022-34038/): Denial of service in n/a (high 7.5)
- [CVE-2018-16886](https://insights.sbomify.com/CVE-2018-16886/): go.etcd.io/etcd Authentication Bypass (medium 6.8)
- [CVE-2026-59818](https://insights.sbomify.com/CVE-2026-59818/): etcd: gRPC client listener does not enforce `--client-crl-file` certificate revocation (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44283 and fix it if it is affected.

What it is: CVE-2026-44283 is a missing authorization vulnerability in etcd-io etcd, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44283 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.etcd.io/etcd/v3 (Go): affected from 3.5.0; fixed in 3.5.30
- go.etcd.io/etcd/v3 (Go): affected from 3.5.0; fixed in 3.5.30
- go.etcd.io/etcd/v3 (Go): affected from 3.6.0; fixed in 3.6.11
- go.etcd.io/etcd/v3 (Go): affected from 3.6.0; fixed in 3.6.11
- etcd (Bitnami): affected all versions; fixed in 3.4.44, 3.5.30, 3.6.11
- go.etcd.io/etcd (Go): affected all versions; fixed in 3.4.44
- go.etcd.io/etcd (Go): affected all versions; fixed in 3.4.44
- go.etcd.io/etcd/server/v3 (Go): affected from 3.5.0; fixed in 3.5.30, 3.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44283/ (Markdown: https://insights.sbomify.com/CVE-2026-44283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44283
- OSV: https://osv.dev/vulnerability/CVE-2026-44283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44283/
Summaries are generated and may contain mistakes; the official description above is the record.
