# CVE-2026-44284: FastGPT: Stored MCP tool URL SSRF in FastGPT workflow execution

> Authenticated users can store internal URLs in MCP tools, causing the backend to connect to internal services during workflow execution.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-cxxj-99f7-f5wq

## What is CVE-2026-44284?

CVE-2026-44284 is a medium-severity server-side request forgery vulnerability in labring FastGPT, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FastGPT is an AI Agent building platform. Prior to version 4.14.17, FastGPT had an inconsistent SSRF protection gap in MCP tool URL handling. The direct MCP preview/run endpoints already rejected internal/private network URLs, but the MCP tool create/update endpoints could still save an internal MCP server URL. That stored URL could later be used by workflow execution without revalidating the destination. An authenticated user with permission to create or manage MCP toolsets could store an internal endpoint such as http://localhost:3000/mcp and later cause the FastGPT backend workflow runner to connect to that internal destination. This issue has been patched in version 4.14.17.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44284?


## How do I fix CVE-2026-44284?

No fix has been published for CVE-2026-44284 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44284 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44284 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44284 and fix it if it is affected.

What it is: CVE-2026-44284 is a medium-severity server-side request forgery vulnerability in labring FastGPT, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44284 exists.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44284/ (Markdown: https://insights.sbomify.com/CVE-2026-44284/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44284
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44284
- OSV: https://osv.dev/vulnerability/CVE-2026-44284

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44284/
Summaries are generated and may contain mistakes; the official description above is the record.
