# CVE-2026-44285: FastGPT: SSRF Protection Bypass via `externalFile` in Dataset Preview API

> Authenticated attackers can bypass SSRF protections in FastGPT to access internal network services via the dataset preview API.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-c65v-7vx6-f8m3

## What is CVE-2026-44285?

CVE-2026-44285 is a high-severity server-side request forgery vulnerability in labring FastGPT, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FastGPT is an AI Agent building platform. Prior to 4.15.0-beta1, a Server-Side Request Forgery (SSRF) vulnerability allows an authenticated attacker to bypass the global isInternalAddress network protection and make arbitrary HTTP GET requests to internal network services. This is achieved by exploiting an incomplete fix in the dataset preview endpoint /api/core/dataset/file/getPreviewChunks when utilizing the externalFile data import type. This vulnerability is fixed in 4.15.0-beta1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44285?


## How do I fix CVE-2026-44285?

No fix has been published for CVE-2026-44285 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44285 being exploited?

There is no known exploitation of CVE-2026-44285 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44285 and fix it if it is affected.

What it is: CVE-2026-44285 is a high-severity server-side request forgery vulnerability in labring FastGPT, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44285 in the wild and no public exploit code.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44285/ (Markdown: https://insights.sbomify.com/CVE-2026-44285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44285
- OSV: https://osv.dev/vulnerability/CVE-2026-44285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44285/
Summaries are generated and may contain mistakes; the official description above is the record.
