# CVE-2026-44286: FastGPT: SSRF Vulnerability in Laf Workflow Node via Missing Internal Address Validation

> Unauthenticated attackers can send arbitrary HTTP requests to internal networks via a workflow node, bypassing SSRF protections in FastGPT.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 May 2026
- **Updated:** 11 May 2026
- **Also known as:** GHSA-xpx6-xcpf-76qg

## What is CVE-2026-44286?

CVE-2026-44286 is a low-severity server-side request forgery vulnerability in labring FastGPT, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FastGPT is an AI Agent building platform. Prior to version 4.14.17, an unauthenticated Server-Side Request Forgery (SSRF) vulnerability allows attackers (or authenticated users with App editing privileges) to send arbitrary HTTP requests to internal/private network addresses. The fetchData function in the lafModule workflow node uses axios to fetch user-controlled URLs without validating them against the application's internal network blocklist guard (isInternalAddress), bypassing SSRF protections. This issue has been patched in version 4.14.17.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44286?


## How do I fix CVE-2026-44286?

No fix has been published for CVE-2026-44286 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44286 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44286 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44286 and fix it if it is affected.

What it is: CVE-2026-44286 is a low-severity server-side request forgery vulnerability in labring FastGPT, published on 8 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44286 exists.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44286/ (Markdown: https://insights.sbomify.com/CVE-2026-44286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44286
- OSV: https://osv.dev/vulnerability/CVE-2026-44286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44286/
Summaries are generated and may contain mistakes; the official description above is the record.
