# CVE-2026-44287: FastGPT: sandbox escape to RCE - code-sandbox regex /\bimport\s*\(/ is bypassable

> Attackers can bypass sandbox restrictions to execute arbitrary commands via dynamic import injection in FastGPT.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-f5mq-qxm4-5mvc

## What is CVE-2026-44287?

CVE-2026-44287 is a medium-severity code injection vulnerability in labring FastGPT, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FastGPT is an AI Agent building platform. Prior to 4.15.0-beta1, the JavaScript sandbox worker at projects/code-sandbox/src/pool/worker.ts:356 blocks dynamic import() with the regex /\bimport\s*\(/.test(code). JavaScript syntax accepts a block comment between import and (; the regex matches only ASCII whitespace, and the bytes /, *, *, / are not in the \s character class. The payload import/**/("child_process") parses as a syntactically valid dynamic import that the regex does not detect. Because import() is not wrapped by the safeRequire Proxy (which only proxies require), the attacker loads child_process and calls execSync - arbitrary command execution as uid=100(sandbox) inside the sandbox container. This vulnerability is fixed in 4.15.0-beta1.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-44287?


## How do I fix CVE-2026-44287?

No fix has been published for CVE-2026-44287 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44287 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44287 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44287 and fix it if it is affected.

What it is: CVE-2026-44287 is a medium-severity code injection vulnerability in labring FastGPT, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44287 exists.

Affected product: labring FastGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44287/ (Markdown: https://insights.sbomify.com/CVE-2026-44287/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44287
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44287
- OSV: https://osv.dev/vulnerability/CVE-2026-44287

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44287/
Summaries are generated and may contain mistakes; the official description above is the record.
