# CVE-2026-44288: protobufjs: Overlong UTF-8 decoding

> Attackers can bypass application-level byte checks by using overlong UTF-8 sequences in protobuf data, potentially evading security filters.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 13 May 2026
- **Also known as:** CLEANSTART-2026-GG71544, CLEANSTART-2026-QH47034, CLSA-2026-1778805971, CLSA-2026-1780966319, CLSA-2026-1792161466, CLSA-2026-1792510240, ECHO-72a3-0efc-e50d, GHSA-q6x5-8v7m-xcrf, MINI-28mh-hxc7-j457, MINI-4g4q-v3fc-xwrm, MINI-5chx-x6v3-jx83, MINI-5x56-wrv7-h4mm, MINI-69gg-v7w5-385x, MINI-6xfh-3842-c55m, MINI-83j3-qq7c-9cgh, MINI-8mxr-hj4r-cqxh, MINI-g845-rx2c-7w58, MINI-jw2v-jccr-49ph, MINI-mf86-rmjj-96mj, MINI-mxqh-ww2v-9m3c, MINI-pxxm-p5jp-p6h3, MINI-rr78-5wwh-mvjf, MINI-v2qc-qrpq-hvcp, MINI-xww7-5rrv-43w5, ROOT-APP-NPM-CVE-2026-44288

## What is CVE-2026-44288?

CVE-2026-44288 is a medium-severity vulnerability in protobufjs protobuf.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

protobufjs compiles protobuf definitions into JavaScript (JS) functions. Prior to 7.5.6 and 8.0.2, protobufjs includes a minimal UTF-8 decoder that accepted overlong UTF-8 byte sequences and decoded them to their canonical characters instead of replacing them. An attacker who can provide protobuf binary data decoded through the affected UTF-8 path may be able to bypass application-level checks that inspect raw bytes before protobuf string decoding. For example, bytes that do not contain certain ASCII characters could decode to strings containing those characters. This vulnerability is fixed in 7.5.6 and 8.0.2.

Weakness: CWE-176 (Improper Handling of Unicode Encoding)

## Which versions are affected by CVE-2026-44288?

6 open source packages ship an affected version, including protobufjs and @protobufjs/utf8. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `protobufjs` | npm | All versions | 7.5.6 |
| `protobufjs` | npm | All versions | 7.5.6 |
| `protobufjs` | npm | From 8.0.0 | 8.0.2 |
| `protobufjs` | npm | From 8.0.0 | 8.0.2 |
| `@protobufjs/utf8` | npm | All versions | 1.1.1 |
| `@protobufjs/utf8` | npm | All versions | 1.1.1 |

Products: Protobufjs Project Protobufjs.

## How do I fix CVE-2026-44288?

Upgrade protobufjs to a fixed version for your release line: 7.5.6 or 8.0.2.

## Is CVE-2026-44288 being exploited?

There is no known exploitation of CVE-2026-44288 in the wild and no public exploit code.

## Other vulnerabilities in protobufjs protobuf.js

- [CVE-2023-36665](https://insights.sbomify.com/CVE-2023-36665/): protobufjs Prototype Pollution vulnerability (critical 9.8)
- [CVE-2026-41242](https://insights.sbomify.com/CVE-2026-41242/): protobufjs has an arbitrary code execution issue (critical 9.4)
- [CVE-2022-25878](https://insights.sbomify.com/CVE-2022-25878/): Prototype Pollution (high 8.2)
- [CVE-2026-44291](https://insights.sbomify.com/CVE-2026-44291/): protobufjs: Code generation gadget after prototype pollution (high 8.1)
- [CVE-2026-44293](https://insights.sbomify.com/CVE-2026-44293/): protobufjs: Code injection through bytes field defaults in generated toObject code (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44288 and fix it if it is affected.

What it is: CVE-2026-44288 is a medium-severity vulnerability in protobufjs protobuf.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44288 in the wild and no public exploit code.

Affected packages and fixed versions:
- protobufjs (npm): affected all versions; fixed in 7.5.6
- protobufjs (npm): affected all versions; fixed in 7.5.6
- protobufjs (npm): affected from 8.0.0; fixed in 8.0.2
- protobufjs (npm): affected from 8.0.0; fixed in 8.0.2
- @protobufjs/utf8 (npm): affected all versions; fixed in 1.1.1
- @protobufjs/utf8 (npm): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44288/ (Markdown: https://insights.sbomify.com/CVE-2026-44288/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44288
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44288
- OSV: https://osv.dev/vulnerability/CVE-2026-44288

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44288/
Summaries are generated and may contain mistakes; the official description above is the record.
