# CVE-2026-44289: protobufjs: Denial of service through unbounded protobuf recursion

> Attackers can cause denial of service in applications using protobufjs by sending crafted payloads that exhaust the JavaScript call stack during decoding.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 28 Aug 2026
- **Also known as:** CLEANSTART-2026-BJ95766, CLEANSTART-2026-FR90298, CLEANSTART-2026-MV58363, ECHO-41c7-1f62-5d4b, GHSA-685m-2w69-288q, MINI-2h37-74x7-f679, MINI-2v38-fhgr-8q6g, MINI-2xcp-54rw-hm93, MINI-3xcm-3gg9-vcwh, MINI-5fmc-rmqg-988q, MINI-6cp3-r6xr-ph2q, MINI-8jq4-r64w-3chg, MINI-9h77-3r6m-pm4x, MINI-c76c-7jm9-q9pp, MINI-g6xm-hxfp-3p6q, MINI-hm7c-h3r6-893v, MINI-hpv9-jxjg-j285, MINI-jwj7-jgj2-cw3c, MINI-m68f-q534-w82q, MINI-r6p4-cgvx-p285, MINI-vh3p-ghh2-g3m2, ROOT-APP-NPM-CVE-2026-44289

## What is CVE-2026-44289?

CVE-2026-44289 is a high-severity denial of service vulnerability in protobufjs protobuf.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

protobufjs compiles protobuf definitions into JavaScript (JS) functions. Prior to 7.5.6 and 8.0.2, protobufjs could recurse without a depth limit while decoding nested protobuf data. This affected both skipping unknown group fields and generated decoding of nested message fields. A crafted protobuf binary payload could cause the JavaScript call stack to be exhausted during decoding. This vulnerability is fixed in 7.5.6 and 8.0.2.

Weakness: CWE-606 (Unchecked Input for Loop Condition), CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-44289?

4 open source packages ship an affected version, including protobufjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `protobufjs` | npm | All versions | 7.5.6 |
| `protobufjs` | npm | All versions | 7.5.6 |
| `protobufjs` | npm | From 8.0.0 | 8.0.2 |
| `protobufjs` | npm | From 8.0.0 | 8.0.2 |

Products: Protobufjs Project Protobufjs.

## How do I fix CVE-2026-44289?

Upgrade protobufjs to a fixed version for your release line: 7.5.6 or 8.0.2.

## Is CVE-2026-44289 being exploited?

There is no known exploitation of CVE-2026-44289 in the wild and no public exploit code.

## Other vulnerabilities in protobufjs protobuf.js

- [CVE-2023-36665](https://insights.sbomify.com/CVE-2023-36665/): protobufjs Prototype Pollution vulnerability (critical 9.8)
- [CVE-2026-41242](https://insights.sbomify.com/CVE-2026-41242/): protobufjs has an arbitrary code execution issue (critical 9.4)
- [CVE-2022-25878](https://insights.sbomify.com/CVE-2022-25878/): Prototype Pollution (high 8.2)
- [CVE-2026-44291](https://insights.sbomify.com/CVE-2026-44291/): protobufjs: Code generation gadget after prototype pollution (high 8.1)
- [CVE-2026-44293](https://insights.sbomify.com/CVE-2026-44293/): protobufjs: Code injection through bytes field defaults in generated toObject code (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44289 and fix it if it is affected.

What it is: CVE-2026-44289 is a high-severity denial of service vulnerability in protobufjs protobuf.js, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44289 in the wild and no public exploit code.

Affected packages and fixed versions:
- protobufjs (npm): affected all versions; fixed in 7.5.6
- protobufjs (npm): affected all versions; fixed in 7.5.6
- protobufjs (npm): affected from 8.0.0; fixed in 8.0.2
- protobufjs (npm): affected from 8.0.0; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44289/ (Markdown: https://insights.sbomify.com/CVE-2026-44289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44289
- OSV: https://osv.dev/vulnerability/CVE-2026-44289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44289/
Summaries are generated and may contain mistakes; the official description above is the record.
