# CVE-2026-44293: protobufjs: Code injection through bytes field defaults in generated toObject code

> Attackers can execute arbitrary code by crafting a protobuf descriptor with a malicious bytes field default value in protobufjs.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 9 Sep 2026
- **Also known as:** CLEANSTART-2026-AV38227, CLEANSTART-2026-CY64651, CLEANSTART-2026-XF24376, ECHO-0641-6a07-e4b8, GHSA-66ff-xgx4-vchm, MINI-2996-px72-grmg, MINI-4w8j-hmf6-x4qm, MINI-6wqx-vh5g-529j, MINI-7fw2-rxcm-7wf2, MINI-7jmj-4m99-92mf, MINI-87mv-g39g-jxfr, MINI-8rj7-gf72-rm8g, MINI-cfvp-g36p-vjqf, MINI-gmgv-8g3f-vh2g, MINI-hc9v-3497-wjp4, MINI-hq82-j8mh-gfx6, MINI-jjwm-26q2-9frx, MINI-pr2j-jq96-fx8x, MINI-pxqh-3h2q-mwmm, MINI-q6g7-6rv5-px9h, MINI-r796-g29q-gq82, ROOT-APP-NPM-CVE-2026-44293

## What is CVE-2026-44293?

CVE-2026-44293 is a high-severity code injection vulnerability in protobufjs protobuf.js, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

protobufjs compiles protobuf definitions into JavaScript (JS) functions. Prior to 7.5.6 and 8.0.2, protobufjs generated JavaScript for toObject conversion could include an unsafe expression derived from a schema-controlled bytes field default value. A crafted descriptor with a non-string default value for a bytes field could cause attacker-controlled code to be emitted into the generated conversion function. This vulnerability is fixed in 7.5.6 and 8.0.2.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-44293?

4 open source packages ship an affected version, including protobufjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `protobufjs` | npm | All versions | 7.5.6 |
| `protobufjs` | npm | All versions | 7.5.6 |
| `protobufjs` | npm | From 8.0.0 | 8.0.2 |
| `protobufjs` | npm | From 8.0.0 | 8.0.2 |

Products: Protobufjs Project Protobufjs.

## How do I fix CVE-2026-44293?

Upgrade protobufjs to a fixed version for your release line: 7.5.6 or 8.0.2.

## Is CVE-2026-44293 being exploited?

There is no known exploitation of CVE-2026-44293 in the wild and no public exploit code.

## Other vulnerabilities in protobufjs protobuf.js

- [CVE-2023-36665](https://insights.sbomify.com/CVE-2023-36665/): protobufjs Prototype Pollution vulnerability (critical 9.8)
- [CVE-2026-41242](https://insights.sbomify.com/CVE-2026-41242/): protobufjs has an arbitrary code execution issue (critical 9.4)
- [CVE-2022-25878](https://insights.sbomify.com/CVE-2022-25878/): Prototype Pollution (high 8.2)
- [CVE-2026-44291](https://insights.sbomify.com/CVE-2026-44291/): protobufjs: Code generation gadget after prototype pollution (high 8.1)
- [CVE-2026-48712](https://insights.sbomify.com/CVE-2026-48712/): protobufjs: Denial of service through unbounded Any expansion during JSON conversion (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44293 and fix it if it is affected.

What it is: CVE-2026-44293 is a high-severity code injection vulnerability in protobufjs protobuf.js, published on 13 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44293 in the wild and no public exploit code.

Affected packages and fixed versions:
- protobufjs (npm): affected all versions; fixed in 7.5.6
- protobufjs (npm): affected all versions; fixed in 7.5.6
- protobufjs (npm): affected from 8.0.0; fixed in 8.0.2
- protobufjs (npm): affected from 8.0.0; fixed in 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44293/ (Markdown: https://insights.sbomify.com/CVE-2026-44293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44293
- OSV: https://osv.dev/vulnerability/CVE-2026-44293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44293/
Summaries are generated and may contain mistakes; the official description above is the record.
