# CVE-2026-44304: Lemur: LDAP Filter Injection enables post-authentication privilege escalation

> Authenticated users can inject LDAP filters via username to escalate privileges to administrator in Lemur certificate management.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-3r34-vq8m-39gh, PYSEC-2026-2585

## What is CVE-2026-44304?

CVE-2026-44304 is a high-severity vulnerability in Netflix lemur, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lemur manages TLS certificate creation. Prior to 1.9.0, Lemur's LDAP authentication module (lemur/auth/ldap.py) constructs LDAP search filters using unsanitized user input via Python string interpolation. An authenticated LDAP user can inject LDAP filter metacharacters through the username field to manipulate group membership queries and escalate their privileges to administrator. This vulnerability is fixed in 1.9.0.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query)

## Which versions are affected by CVE-2026-44304?

3 open source packages ship an affected version, including lemur.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lemur` | PyPI | All versions | 1.9.0 |
| `lemur` | PyPI | All versions | 1.9.0 |
| `lemur` | PyPI | All versions | 1.9.0 |

## How do I fix CVE-2026-44304?

Upgrade lemur to 1.9.0 or later.

## Is CVE-2026-44304 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44304 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44304 and fix it if it is affected.

What it is: CVE-2026-44304 is a high-severity vulnerability in Netflix lemur, published on 12 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44304 exists.

Affected packages and fixed versions:
- lemur (PyPI): affected all versions; fixed in 1.9.0
- lemur (PyPI): affected all versions; fixed in 1.9.0
- lemur (PyPI): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44304/ (Markdown: https://insights.sbomify.com/CVE-2026-44304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44304
- OSV: https://osv.dev/vulnerability/CVE-2026-44304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44304/
Summaries are generated and may contain mistakes; the official description above is the record.
