# CVE-2026-44307: Mako: Path traversal via backslash URI on Windows in TemplateLookup

> An attacker can read arbitrary files outside the template directory on Windows by using backslash traversal in URIs.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 May 2026
- **Updated:** 13 May 2026
- **Also known as:** CLEANSTART-2026-AF49322, CLEANSTART-2026-MF83934, ECHO-15a8-1150-dd0d, GHSA-2h4p-vjrc-8xpq, MINI-3hf9-jwj9-rr54, MINI-7xgp-g26j-67f7, MINI-c9gg-4hxq-r6wc, MINI-g9vx-w466-5c2j, MINI-qgqh-3g2v-cprc, MINI-r66m-pxwv-x735, PYSEC-2026-2617, ROOT-APP-PYPI-CVE-2026-44307

## What is CVE-2026-44307?

CVE-2026-44307 is a high-severity path traversal vulnerability in sqlalchemy mako, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mako is a template library written in Python. Prior to 1.3.12, on Windows, a URI using backslash traversal (e.g. \..\..\ secret.txt) bypasses the directory traversal check in Template.__init__ and the posixpath-based normalization in TemplateLookup.get_template(), allowing reads of files outside the configured template directory. This vulnerability is fixed in 1.3.12.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44307?

3 open source packages ship an affected version, including mako and Mako.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mako` | PyPI | All versions | 1.3.12 |
| `mako` | PyPI | All versions | 1.3.12 |
| `Mako` | PyPI | All versions | 1.3.12 |

## How do I fix CVE-2026-44307?

Upgrade mako to 1.3.12 or later.

## Is CVE-2026-44307 being exploited?

There is no known exploitation of CVE-2026-44307 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44307 and fix it if it is affected.

What it is: CVE-2026-44307 is a high-severity path traversal vulnerability in sqlalchemy mako, published on 12 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44307 in the wild and no public exploit code.

Affected packages and fixed versions:
- mako (PyPI): affected all versions; fixed in 1.3.12
- mako (PyPI): affected all versions; fixed in 1.3.12
- Mako (PyPI): affected all versions; fixed in 1.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44307/ (Markdown: https://insights.sbomify.com/CVE-2026-44307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44307
- OSV: https://osv.dev/vulnerability/CVE-2026-44307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44307/
Summaries are generated and may contain mistakes; the official description above is the record.
