CVE-2026-44312 css_parser allows to MITM included https css urls
Attackers can perform Man-in-the-Middle attacks to inject or modify CSS content because the library fails to validate HTTPS certificates.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44312?
CVE-2026-44312 is a medium-severity vulnerability in premailer css_parser, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.
Which versions are affected by CVE-2026-44312?
4 open source packages ship an affected version, including css_parser.
| Package | Affected | Fixed in |
|---|---|---|
css_parser RubyGems | All versions | 1.22.0 |
css_parser RubyGems | All versions | 1.22.0 |
css_parser RubyGems | From 2.0.0 | 2.1.0 |
css_parser RubyGems | From 2.0.0 | 2.1.0 |
How do I fix CVE-2026-44312?
Upgrade css_parser to a fixed version for your release line: 1.22.0 or 2.1.0.
Is CVE-2026-44312 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44312 exists.
Sources
Also known as DEBIAN-CVE-2026-44312, GHSA-ff6c-w6qf-7xqc, UBUNTU-CVE-2026-44312.