{"answers":{"affected":"4 open source packages ship an affected version, including css_parser.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44312 exists.","fix":"Upgrade css_parser to a fixed version for your release line: 1.22.0 or 2.1.0.","what":"CVE-2026-44312 is a medium-severity vulnerability in premailer css_parser, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44312 and fix it if it is affected.\n\nWhat it is: CVE-2026-44312 is a medium-severity vulnerability in premailer css_parser, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44312 exists.\n\nAffected packages and fixed versions:\n- css_parser (RubyGems): affected all versions; fixed in 1.22.0\n- css_parser (RubyGems): affected all versions; fixed in 1.22.0\n- css_parser (RubyGems): affected from 2.0.0; fixed in 2.1.0\n- css_parser (RubyGems): affected from 2.0.0; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44312/ (Markdown: https://insights.sbomify.com/CVE-2026-44312/index.md)","id":"CVE-2026-44312","markdown":"https://insights.sbomify.com/CVE-2026-44312/index.md","name":"CVE-2026-44312","record":{"aliases":["DEBIAN-CVE-2026-44312","GHSA-ff6c-w6qf-7xqc","UBUNTU-CVE-2026-44312"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby CSS parser","requires_auth":"none","summary":"Attackers can perform Man-in-the-Middle attacks to inject or modify CSS content because the library fails to validate HTTPS certificates.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"},{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when stylesheets are loaded via HTTPS. The connection is established with OpenSSL::SSL::VERIFY_NONE, meaning any HTTPS certificate—even entirely untrusted—will be accepted without validation. This vulnerability is fixed in 2.1.0 and 1.22.0.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"css_parser allows to MITM included https css urls","id":"CVE-2026-44312","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"LinkWarden: Server-Side Request Forgery (SSRF) in Link Creation via fetchTitleAndHeaders Function","id":"CVE-2026-44313"},"packages":[{"ecosystem":"RubyGems","fixed":["1.22.0"],"introduced":["0"],"last_affected":[],"package":"css_parser","purl":null,"source":"GHSA-ff6c-w6qf-7xqc"},{"ecosystem":"RubyGems","fixed":["1.22.0"],"introduced":["0"],"last_affected":[],"package":"css_parser","purl":"pkg:gem/css_parser","source":"GHSA-ff6c-w6qf-7xqc"},{"ecosystem":"RubyGems","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"css_parser","purl":null,"source":"GHSA-ff6c-w6qf-7xqc"},{"ecosystem":"RubyGems","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"css_parser","purl":"pkg:gem/css_parser","source":"GHSA-ff6c-w6qf-7xqc"}],"prev":{"headline":"Fabric.js: Improper escaping in fabric.Gradient colorStops leads to XSS in SVG serialization","id":"CVE-2026-44311"},"products":["css_parser"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-15","vendors":["premailer"]},"summary":"Attackers can perform Man-in-the-Middle attacks to inject or modify CSS content because the library fails to validate HTTPS certificates.","url":"https://insights.sbomify.com/CVE-2026-44312/"}