# CVE-2026-44315: free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions

> Attackers can create, read, and delete PFD transactions in free5GC NEF by bypassing authentication with forged tokens, affecting 5G core network operators.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-5f62-53r8-qrqf, GO-2026-5142

## What is CVE-2026-44315?

CVE-2026-44315 is a critical missing authorization vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's NEF mounts the 3gpp-pfd-management API without inbound OAuth2/bearer-token authorization. A network attacker who can reach NEF on the SBI can create, read, and delete PFD-management transaction state with a forged or arbitrary bearer token (e.g. Authorization: Bearer not-a-real-token). The route group is also reachable even when the running config's ServiceList does not declare it, so operators who think they disabled the service via config are still exposed. This vulnerability is fixed in 4.2.2.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-44315?

3 open source packages ship an affected version, including github.com/free5gc/nef. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/nef` | Go | All versions | None |
| `github.com/free5gc/nef` | Go | All versions to 1.2.3 | None |
| `github.com/free5gc/nef` | Go | All versions to 1.2.3 | None |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-44315?

Upgrade to a fixed version.

## Is CVE-2026-44315 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44315 exists.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44326](https://insights.sbomify.com/CVE-2026-44326/): free5GC's NEF 3gpp-traffic-influence API is unauthenticated; missing or forged bearer tokens can create, read, patch, and delete subscriptions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44315 and fix it if it is affected.

What it is: CVE-2026-44315 is a critical missing authorization vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44315 exists.

Affected packages and fixed versions:
- github.com/free5gc/nef (Go): affected all versions; no fix listed
- github.com/free5gc/nef (Go): affected all versions up to 1.2.3; no fix listed
- github.com/free5gc/nef (Go): affected all versions up to 1.2.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44315/ (Markdown: https://insights.sbomify.com/CVE-2026-44315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44315
- OSV: https://osv.dev/vulnerability/CVE-2026-44315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44315/
Summaries are generated and may contain mistakes; the official description above is the record.
