CVE-2026-44316 free5GC: PCF npcf-smpolicycontrol POST /sm-policies panics on downstream UDR/OpenAPI 404 via nil pointer dereference
An attacker can cause a panic and service disruption in free5GC PCF by sending a POST request that triggers a downstream 404 error, leading to a nil pointer dereference.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-44316?
CVE-2026-44316 is a high-severity vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's PCF POST /npcf-smpolicycontrol/v1/sm-policies handler (HandleCreateSmPolicyRequest) panics with a nil-pointer dereference when a downstream OpenAPI consumer call (UDR lookup) returns 404 Not Found and the consumer wrapper returns err != nil together with a nil response struct. The handler logs the OpenAPI error and continues executing instead of returning, then dereferences the nil response struct on a subsequent line and panics. Gin recovery converts the panic into HTTP 500, so a single attacker-shaped POST returns 500 instead of a clean 4xx whenever the downstream lookup fails. The PCF process keeps running. The trigger is a single POST containing input that causes the downstream UDR lookup to fail (e.g. an unknown DNN). In 4.2.1 this endpoint is also reachable WITHOUT an Authorization header because the PCF Npcf_SMPolicyControl route group is mounted without inbound auth middleware. This vulnerability is fixed in 4.2.2.
Which versions are affected by CVE-2026-44316?
3 open source packages ship an affected version, including github.com/free5gc/pcf. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/free5gc/pcf Go | All versions | 1.4.2 |
github.com/free5gc/pcf Go | All versions | 1.4.2 |
github.com/free5gc/pcf Go | All versions | 1.4.2 |
Products include Free5gc Free5gc.
How do I fix CVE-2026-44316?
Upgrade github.com/free5gc/pcf to 1.4.2 or later.
Is CVE-2026-44316 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44316 exists.
Other vulnerabilities in Free5gc Free5gc
- CVE-2026-44327 free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler
- CVE-2026-44329 free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers
- CVE-2026-44330 free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions
- CVE-2025-63679 Memory corruption in n/a
- CVE-2026-44315 free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions
Sources
Also known as GHSA-wr8j-6chw-gm6p, GO-2026-5720.