# CVE-2026-44316: free5GC: PCF npcf-smpolicycontrol POST /sm-policies panics on downstream UDR/OpenAPI 404 via nil pointer dereference

> An attacker can cause a panic and service disruption in free5GC PCF by sending a POST request that triggers a downstream 404 error, leading to a nil pointer dereference.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-wr8j-6chw-gm6p, GO-2026-5720

## What is CVE-2026-44316?

CVE-2026-44316 is a high-severity vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's PCF POST /npcf-smpolicycontrol/v1/sm-policies handler (HandleCreateSmPolicyRequest) panics with a nil-pointer dereference when a downstream OpenAPI consumer call (UDR lookup) returns 404 Not Found and the consumer wrapper returns err != nil together with a nil response struct. The handler logs the OpenAPI error and continues executing instead of returning, then dereferences the nil response struct on a subsequent line and panics. Gin recovery converts the panic into HTTP 500, so a single attacker-shaped POST returns 500 instead of a clean 4xx whenever the downstream lookup fails. The PCF process keeps running. The trigger is a single POST containing input that causes the downstream UDR lookup to fail (e.g. an unknown DNN). In 4.2.1 this endpoint is also reachable WITHOUT an Authorization header because the PCF Npcf_SMPolicyControl route group is mounted without inbound auth middleware. This vulnerability is fixed in 4.2.2.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-44316?

3 open source packages ship an affected version, including github.com/free5gc/pcf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.2 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.2 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.2 |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-44316?

Upgrade github.com/free5gc/pcf to 1.4.2 or later.

## Is CVE-2026-44316 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44316 exists.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44316 and fix it if it is affected.

What it is: CVE-2026-44316 is a high-severity vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44316 exists.

Affected packages and fixed versions:
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.2
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44316/ (Markdown: https://insights.sbomify.com/CVE-2026-44316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44316
- OSV: https://osv.dev/vulnerability/CVE-2026-44316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44316/
Summaries are generated and may contain mistakes; the official description above is the record.
