# CVE-2026-44317: free5GC's PCF npcf-policyauthorization POST /app-sessions panics on suppFeat=1 with missing AfRoutReq via nil pointer dereference

> An authenticated attacker can crash the free5GC PCF service by sending a specific policy authorization request, causing a denial of service.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-wwqh-7jm5-gj7w, GO-2026-5731

## What is CVE-2026-44317?

CVE-2026-44317 is a medium-severity vulnerability in Free5gc Free5gc, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's PCF POST /npcf-policyauthorization/v1/app-sessions handler panics on a single authenticated request whose ascReqData.suppFeat == "1" (enabling traffic-routing feature negotiation) and whose medComponents entries supply an afAppId but NO AfRoutReq. The create path then calls provisioningOfTrafficRoutingInfo(smPolicy, appID, routeReq, ...) with routeReq == nil and dereferences routeReq.RouteToLocs (and other fields) without a nil check, causing runtime error: invalid memory address or nil pointer dereference. Gin recovery converts the panic into HTTP 500. This vulnerability is fixed in 4.2.2.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-44317?

3 open source packages ship an affected version, including github.com/free5gc/pcf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/pcf` | Go | All versions | 1.4.3 |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-44317?

Upgrade github.com/free5gc/pcf to 1.4.3 or later.

## Is CVE-2026-44317 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44317 exists.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44317 and fix it if it is affected.

What it is: CVE-2026-44317 is a medium-severity vulnerability in Free5gc Free5gc, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44317 exists.

Affected packages and fixed versions:
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/pcf (Go): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44317/ (Markdown: https://insights.sbomify.com/CVE-2026-44317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44317
- OSV: https://osv.dev/vulnerability/CVE-2026-44317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44317/
Summaries are generated and may contain mistakes; the official description above is the record.
