# CVE-2026-44328: free5GC's SMF UPI DELETE /upi/v1/upNodesLinks/{ref} panics on AN-node deletion via nil UPF dereference; unauthenticated, state-mutating

> Unauthenticated attackers can crash the SMF and corrupt user-plane topology via a nil-pointer dereference in the UPI management API.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-p9mg-74mg-cwwr, GO-2026-5537

## What is CVE-2026-44328?

CVE-2026-44328 is a high-severity vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

free5GC is an open-source implementation of the 5G core network. Prior to 4.2.2, free5GC's SMF mounts the UPI management route group without inbound OAuth2 middleware. On top of that, the DELETE /upi/v1/upNodesLinks/{upNodeRef} handler unconditionally dereferences upNode.UPF after the type-guarded async release, even though AN-typed nodes are constructed without a UPF object. As a result, a single unauthenticated DELETE /upi/v1/upNodesLinks/gNB1 request crashes the handler with a nil-pointer panic AND mutates the in-memory user-plane topology before panicking (the UpNodeDelete(upNodeRef) line runs first). This is an unauthenticated, state-mutating panic-DoS sink that an off-path network attacker can trigger by name against any AN entry. This vulnerability is fixed in 4.2.2.

Weakness: CWE-862 (Missing Authorization), CWE-476 (NULL Pointer Dereference), CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-44328?

3 open source packages ship an affected version, including github.com/free5gc/smf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/free5gc/smf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/smf` | Go | All versions | 1.4.3 |
| `github.com/free5gc/smf` | Go | All versions | 1.4.3 |

Products: Free5gc Free5gc.

## How do I fix CVE-2026-44328?

Upgrade github.com/free5gc/smf to 1.4.3 or later.

## Is CVE-2026-44328 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44328 exists.

## Other vulnerabilities in Free5gc Free5gc

- [CVE-2026-44327](https://insights.sbomify.com/CVE-2026-44327/): free5GC: NEF nnef-oam route group is unauthenticated; no-token requests reach the OAM handler (critical 10.0)
- [CVE-2026-44329](https://insights.sbomify.com/CVE-2026-44329/): free5GC's SMF UPI management interface lacks auth middleware; unauthenticated topology read/write requests reach handlers (critical 10.0)
- [CVE-2026-44330](https://insights.sbomify.com/CVE-2026-44330/): free5GC's NEF nnef-pfdmanagement API is unauthenticated; forged bearer tokens can read PFD data and create/delete PFD subscriptions (critical 10.0)
- [CVE-2025-63679](https://insights.sbomify.com/CVE-2025-63679/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-44315](https://insights.sbomify.com/CVE-2026-44315/): free5GC's NEF 3gpp-pfd-management API is unauthenticated; forged bearer tokens can create, read, and delete PFD transactions (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44328 and fix it if it is affected.

What it is: CVE-2026-44328 is a high-severity vulnerability in Free5gc Free5gc, published on 27 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44328 exists.

Affected packages and fixed versions:
- github.com/free5gc/smf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/smf (Go): affected all versions; fixed in 1.4.3
- github.com/free5gc/smf (Go): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44328/ (Markdown: https://insights.sbomify.com/CVE-2026-44328/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44328
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44328
- OSV: https://osv.dev/vulnerability/CVE-2026-44328

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44328/
Summaries are generated and may contain mistakes; the official description above is the record.
