# CVE-2026-44334: PraisonAI: Unauthenticated RCE via `tool_override.py`

> Unauthenticated attackers can execute arbitrary code by uploading a malicious tools.py file via the recipe runner endpoint.

- **Severity:** High 8.4 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-xcmw-grxf-wjhj, PYSEC-2026-2926

## What is CVE-2026-44334?

CVE-2026-44334 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. From version 4.5.139 to before version 4.6.32, CVE-2026-40287's fix gated tools.py auto-import behind PRAISONAI_ALLOW_LOCAL_TOOLS=true in two files (tool_resolver.py, api/call.py). A third import sink in praisonai/templates/tool_override.py was missed and remains unguarded. It is reached by the recipe runner on every recipe execution and is remotely triggerable through POST /v1/recipes/run with a recipe value pointing at any local absolute path or any GitHub repo (because SecurityConfig.allow_any_github defaults to True). The attacker drops a tools.py next to TEMPLATE.yaml; the server exec_module()s it. No auth required by default, no environment opt-in required. This issue has been patched in version 4.6.32.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-44334?

3 open source packages ship an affected version, including praisonai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 4.5.139 | 4.6.32 |
| `praisonai` | PyPI | From 4.5.139 | 4.6.32 |
| `praisonai` | PyPI | From 4.5.139 | 4.6.32 |

Products: Praison Praisonai.

## How do I fix CVE-2026-44334?

Upgrade praisonai to 4.6.32 or later.

## Is CVE-2026-44334 being exploited?

There is no known exploitation of CVE-2026-44334 in the wild and no public exploit code.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44334 and fix it if it is affected.

What it is: CVE-2026-44334 is a high-severity code injection vulnerability in MervinPraison PraisonAI, published on 8 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44334 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 4.5.139; fixed in 4.6.32
- praisonai (PyPI): affected from 4.5.139; fixed in 4.6.32
- praisonai (PyPI): affected from 4.5.139; fixed in 4.6.32

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44334/ (Markdown: https://insights.sbomify.com/CVE-2026-44334/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44334
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44334
- OSV: https://osv.dev/vulnerability/CVE-2026-44334

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44334/
Summaries are generated and may contain mistakes; the official description above is the record.
