# CVE-2026-44338: PraisonAI ships and generates a legacy API server with authentication disabled by default, allowing unauthenticated workflow execution

> Unauthenticated attackers can execute arbitrary AI workflows and access agent data in PraisonAI due to disabled authentication in the default legacy API server.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-6rmh-7xcm-cpxj, PYSEC-2026-2904

## What is CVE-2026-44338?

CVE-2026-44338 is a high-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. From version 2.5.6 to before version 4.6.34, PraisonAI ships a legacy Flask API server with authentication disabled by default. When that server is used, any caller that can reach it can access /agents and trigger the configured agents.yaml workflow through /chat without providing a token. This issue has been patched in version 4.6.34.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-306 (Missing Authentication for Critical Functionality), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-44338?

3 open source packages ship an affected version, including praisonai and PraisonAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | From 2.5.6 | 4.6.34 |
| `praisonai` | PyPI | From 2.5.6 | 4.6.34 |
| `PraisonAI` | PyPI | From 2.5.6 | 4.6.34 |

Products: Praison Praisonai.

## How do I fix CVE-2026-44338?

Upgrade praisonai to 4.6.34 or later.

## Is CVE-2026-44338 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44338 exists.

Public exploit code:

- CVE-2026-44338 (github_poc): https://github.com/HORKimhab/CVE-2026-44338
- https://github.com/rootdirective-sec/CVE-2026-44338-Lab (github_poc): https://github.com/rootdirective-sec/CVE-2026-44338-Lab
- PraisonAI - Authentication Bypass (nuclei): http/cves/2026/CVE-2026-44338.yaml

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44338 and fix it if it is affected.

What it is: CVE-2026-44338 is a high-severity missing authorization vulnerability in MervinPraison PraisonAI, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44338 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected from 2.5.6; fixed in 4.6.34
- praisonai (PyPI): affected from 2.5.6; fixed in 4.6.34
- PraisonAI (PyPI): affected from 2.5.6; fixed in 4.6.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44338/ (Markdown: https://insights.sbomify.com/CVE-2026-44338/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44338
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44338
- OSV: https://osv.dev/vulnerability/CVE-2026-44338

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44338/
Summaries are generated and may contain mistakes; the official description above is the record.
