# CVE-2026-44340: PraisonAI: Symlink-extraction bypass of `_safe_extractall` writes outside `dest_dir`

> Attackers can write arbitrary files outside the intended directory via symlink extraction bypass in PraisonAI, potentially leading to code execution.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 8 May 2026
- **Also known as:** GHSA-9q28-ghcr-c4x3, PYSEC-2026-2909

## What is CVE-2026-44340?

CVE-2026-44340 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to version 4.6.37, the _safe_extractall helper that all recipe pull, recipe publish, and recipe unpack flows route through validates each archive member's name for absolute paths, .. segments, and resolved-path escape — but does not validate member.linkname, does not reject symlink/hardlink members, and calls tar.extractall(dest_dir) without filter="data". A bundle that contains a symlink with a name inside dest_dir but a linkname pointing outside it, followed by a regular file whose path traverses through the just-created symlink, escapes dest_dir and lets the attacker write arbitrary content to an attacker-chosen location on the victim's filesystem. This issue has been patched in version 4.6.37.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44340?

3 open source packages ship an affected version, including praisonai and PraisonAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.6.37 |
| `praisonai` | PyPI | All versions | 4.6.37 |
| `PraisonAI` | PyPI | All versions | 4.6.37 |

Products: Praison Praisonai.

## How do I fix CVE-2026-44340?

Upgrade praisonai to 4.6.37 or later.

## Is CVE-2026-44340 being exploited?

There is no known exploitation of CVE-2026-44340 in the wild and no public exploit code.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44340 and fix it if it is affected.

What it is: CVE-2026-44340 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44340 in the wild and no public exploit code.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.6.37
- praisonai (PyPI): affected all versions; fixed in 4.6.37
- PraisonAI (PyPI): affected all versions; fixed in 4.6.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44340/ (Markdown: https://insights.sbomify.com/CVE-2026-44340/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44340
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44340
- OSV: https://osv.dev/vulnerability/CVE-2026-44340

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44340/
Summaries are generated and may contain mistakes; the official description above is the record.
