# CVE-2026-44348: PoDoFo: Double-free vulnerability in compute_hash_to_sign()

> A double-free vulnerability in PoDoFo allows attackers to cause heap corruption, potentially leading to code execution or denial of service.

- **Severity:** Low 2.5 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-8fq6-rqpv-xq72, SUSE-SU-2026:2309-1, UBUNTU-CVE-2026-44348, openSUSE-SU-2026:10970-1

## What is CVE-2026-44348?

CVE-2026-44348 is a low-severity use after free vulnerability in podofo, published on 14 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PoDoFo is a C++17 PDF manipulation library. From 1.0.0 to before 1.0.4, a double-free vulnerability exists in compute_hash_to_sign() in src/podofo/private/OpenSSLInternal_Ripped.cpp. If EVP_DigestFinal fails after buf has already been freed, the Error label frees buf a second time, causing heap corruption. This vulnerability is fixed in 1.0.4.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2026-44348?


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `podofo` | SUSE:Linux Enterprise Module for Package Hub 15 SP7 | All versions | 1.0.2-150700.3.6.1 |
| `podofo` | openSUSE:Tumbleweed | All versions | 1.1.0-1.1 |

## How do I fix CVE-2026-44348?

Upgrade to a fixed version.

## Is CVE-2026-44348 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44348 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44348 and fix it if it is affected.

What it is: CVE-2026-44348 is a low-severity use after free vulnerability in podofo, published on 14 May 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44348 exists.

Affected product: podofo. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44348/ (Markdown: https://insights.sbomify.com/CVE-2026-44348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44348
- OSV: https://osv.dev/vulnerability/CVE-2026-44348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44348/
Summaries are generated and may contain mistakes; the official description above is the record.
