{"answers":{"affected":"3 open source packages ship an affected version, including misp-modules.","exploited":"There is no known exploitation of CVE-2026-44363 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-44363 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-44363 is a medium-severity server-side request forgery vulnerability in misp-modules, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44363 and fix it if it is affected.\n\nWhat it is: CVE-2026-44363 is a medium-severity server-side request forgery vulnerability in misp-modules, published on 13 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44363 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- misp-modules (PyPI): affected all versions up to 3.0.7; no fix listed\n- misp-modules (PyPI): affected all versions up to 3.0.7; no fix listed\n- misp-modules (PyPI): affected all versions up to 3.0.7; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44363/ (Markdown: https://insights.sbomify.com/CVE-2026-44363/index.md)","id":"CVE-2026-44363","markdown":"https://insights.sbomify.com/CVE-2026-44363/index.md","name":"CVE-2026-44363","record":{"aliases":["GHSA-fhq3-2gf3-8f3j","PYSEC-2026-2650"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"MISP expansion modules","requires_auth":"none","summary":"Attackers can exploit unsafe URL fetching in MISP modules to access internal network resources or intercept traffic via disabled TLS verification.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"},{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"MISP modules are autonomous modules that can be used to extend MISP for new services. Prior to 3.0.7, an unsafe remote resource fetching vulnerability existed in MISP Modules expansion modules. The html_to_markdown module accepted arbitrary HTTP(S) URLs without sufficient validation, which could allow Server-Side Request Forgery against loopback, private, or link-local network resources. Additionally, the qrcode module disabled TLS certificate verification when retrieving remote images, exposing requests to potential man-in-the-middle interception or response tampering. The issue was fixed by validating URL schemes, blocking local and private address ranges, resolving hostnames before fetching, enforcing request timeouts, and re-enabling TLS certificate verification. This vulnerability is fixed in 3.0.7.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Unsafe remote resource fetching in expansion misp-modules","id":"CVE-2026-44363","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"misp-modules website - Missing CSRF protection in the website home blueprint","id":"CVE-2026-44364"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.0.7"],"package":"misp-modules","purl":null,"source":"GHSA-fhq3-2gf3-8f3j"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.0.7"],"package":"misp-modules","purl":"pkg:pypi/misp-modules","source":"GHSA-fhq3-2gf3-8f3j"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.0.7"],"package":"misp-modules","purl":"pkg:pypi/misp-modules","source":"PYSEC-2026-2650"}],"prev":{"headline":"OP-TEE's subkey rollback protection can be bypassed with older subkey versions","id":"CVE-2026-44362"},"products":["misp-modules"],"published":"2026-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-14","vendors":["MISP"]},"summary":"Attackers can exploit unsafe URL fetching in MISP modules to access internal network resources or intercept traffic via disabled TLS verification.","url":"https://insights.sbomify.com/CVE-2026-44363/"}