# CVE-2026-44367: Klaw: user lockout due to case sensitivity inconsistency

> Attackers can cause complete account lockout and denial of service in Klaw by exploiting case sensitivity inconsistencies in user registration and login.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Jun 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-75rx-m9vh-mm9p

## What is CVE-2026-44367?

CVE-2026-44367 is a low-severity denial of service vulnerability in Aiven-Open klaw, published on 2 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Klaw is a self-service Apache Kafka Topic Management/Governance tool/portal. Prior to version 2.10.4, a vulnerability exists in the user registration and login mechanisms due to inconsistent handling of username case sensitivity, leading to a targeted Denial of Service (DoS) and complete account lockout. This issue has been patched in version 2.10.4.

Weakness: CWE-20 (Improper Input Validation), CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-44367?


## How do I fix CVE-2026-44367?

No fix has been published for CVE-2026-44367 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44367 being exploited?

There is no known exploitation of CVE-2026-44367 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44367 and fix it if it is affected.

What it is: CVE-2026-44367 is a low-severity denial of service vulnerability in Aiven-Open klaw, published on 2 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44367 in the wild and no public exploit code.

Affected product: Aiven-Open klaw. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44367/ (Markdown: https://insights.sbomify.com/CVE-2026-44367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44367
- OSV: https://osv.dev/vulnerability/CVE-2026-44367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44367/
Summaries are generated and may contain mistakes; the official description above is the record.
