# CVE-2026-44368: PyQuorum: Timing side‑channel in mul_mod

> An attacker can recover secret shares via timing side-channel attacks in the mul_mod function, leading to secret reconstruction.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-7r92-3jgr-r65q, PYSEC-2026-3028

## What is CVE-2026-44368?

CVE-2026-44368 is a medium-severity vulnerability in svvqt pyquorum, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyQuorum is a cryptographic library for secret sharing and key management. Prior to 0.2.1, the mul_mod function implements multiplication via a binary expansion loop whose execution time depends on the Hamming weight of the second operand (the exponent). An attacker who can measure the time of secret‑sharing operations (e.g., via a remote service) could progressively recover the values of shares, ultimately leading to secret reconstruction. This vulnerability is fixed in 0.2.1.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-44368?

3 open source packages ship an affected version, including pyquorum.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyquorum` | PyPI | All versions | 0.2.1 |
| `pyquorum` | PyPI | All versions | 0.2.1 |
| `pyquorum` | PyPI | All versions | 0.2.1 |

## How do I fix CVE-2026-44368?

Upgrade pyquorum to 0.2.1 or later.

## Is CVE-2026-44368 being exploited?

There is no known exploitation of CVE-2026-44368 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44368 and fix it if it is affected.

What it is: CVE-2026-44368 is a medium-severity vulnerability in svvqt pyquorum, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44368 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyquorum (PyPI): affected all versions; fixed in 0.2.1
- pyquorum (PyPI): affected all versions; fixed in 0.2.1
- pyquorum (PyPI): affected all versions; fixed in 0.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44368/ (Markdown: https://insights.sbomify.com/CVE-2026-44368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44368
- OSV: https://osv.dev/vulnerability/CVE-2026-44368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44368/
Summaries are generated and may contain mistakes; the official description above is the record.
