# CVE-2026-44371: Open OnDemand: Specially crafted filenames can execute javascript in the file browser

> Attackers can execute JavaScript in the file browser via crafted filenames, potentially compromising user sessions in Open OnDemand.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-xcv4-m435-m33h

## What is CVE-2026-44371?

CVE-2026-44371 is a medium-severity cross-site scripting vulnerability in OSC ondemand, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Open OnDemand is an open-source high-performance computing portal. Prior to 4.0.11, 4.1.5, and 4.2.2, specially crafted filenames can execute javascript in the file browser This vulnerability is fixed in 4.0.11, 4.1.5, and 4.2.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-44371?


## How do I fix CVE-2026-44371?

No fix has been published for CVE-2026-44371 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44371 being exploited?

There is no known exploitation of CVE-2026-44371 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44371 and fix it if it is affected.

What it is: CVE-2026-44371 is a medium-severity cross-site scripting vulnerability in OSC ondemand, published on 14 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-44371 in the wild and no public exploit code.

Affected product: OSC ondemand. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44371/ (Markdown: https://insights.sbomify.com/CVE-2026-44371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44371
- OSV: https://osv.dev/vulnerability/CVE-2026-44371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44371/
Summaries are generated and may contain mistakes; the official description above is the record.
