# CVE-2026-44374: Backstage: Catalog unprocessed read endpoints allow authenticated cross-owner data access without permission checks

> Authenticated users can access unprocessed entity records from other owners due to missing permission checks in the Backstage catalog plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-p7g9-rp3g-mgfg

## What is CVE-2026-44374?

CVE-2026-44374 is a medium-severity missing authorization vulnerability in @backstage plugin-catalog-backend-module-unprocessed, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals. Prior to 0.6.11, the unprocessed entities read endpoints in @backstage/plugin-catalog-backend-module-unprocessed do not enforce permission authorization checks. Any authenticated user can access unprocessed entity records regardless of ownership. This is an information disclosure vulnerability affecting Backstage installations using this module. This is patched in @backstage/plugin-catalog-backend-module-unprocessed version 0.6.11, @backstage/plugin-catalog-unprocessed-entities-common version 0.0.15 and @backstage/plugin-catalog-unprocessed-entities version 0.2.30.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-44374?

6 open source packages ship an affected version, including @backstage/plugin-catalog-backend-module-unprocessed, @backstage/plugin-catalog-unprocessed-entities and @backstage/plugin-catalog-unprocessed-entities-common. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-catalog-backend-module-unprocessed` | npm | All versions | 0.6.11 |
| `@backstage/plugin-catalog-backend-module-unprocessed` | npm | All versions | 0.6.11 |
| `@backstage/plugin-catalog-unprocessed-entities` | npm | All versions | 0.2.30 |
| `@backstage/plugin-catalog-unprocessed-entities` | npm | All versions | 0.2.30 |
| `@backstage/plugin-catalog-unprocessed-entities-common` | npm | All versions | 0.0.15 |
| `@backstage/plugin-catalog-unprocessed-entities-common` | npm | All versions | 0.0.15 |

Products: Linuxfoundation Backstage\/Plugin-Catalog-Backend-Module-Unprocessed, Linuxfoundation Backstage\/Plugin-Catalog-Unprocessed-Entities, Linuxfoundation Backstage\/Plugin-Catalog-Unprocessed-Entities-Common.

## How do I fix CVE-2026-44374?

Upgrade @backstage/plugin-catalog-backend-module-unprocessed to 0.6.11 or later.

## Is CVE-2026-44374 being exploited?

There is no known exploitation of CVE-2026-44374 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44374 and fix it if it is affected.

What it is: CVE-2026-44374 is a medium-severity missing authorization vulnerability in @backstage plugin-catalog-backend-module-unprocessed, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44374 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-catalog-backend-module-unprocessed (npm): affected all versions; fixed in 0.6.11
- @backstage/plugin-catalog-backend-module-unprocessed (npm): affected all versions; fixed in 0.6.11
- @backstage/plugin-catalog-unprocessed-entities (npm): affected all versions; fixed in 0.2.30
- @backstage/plugin-catalog-unprocessed-entities (npm): affected all versions; fixed in 0.2.30
- @backstage/plugin-catalog-unprocessed-entities-common (npm): affected all versions; fixed in 0.0.15
- @backstage/plugin-catalog-unprocessed-entities-common (npm): affected all versions; fixed in 0.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44374/ (Markdown: https://insights.sbomify.com/CVE-2026-44374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44374
- OSV: https://osv.dev/vulnerability/CVE-2026-44374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44374/
Summaries are generated and may contain mistakes; the official description above is the record.
