# CVE-2026-44377: CubeCart: Server-Side Template Injection (SSTI) in Smarty Templates leading to RCE

> Authenticated administrators can inject code into Smarty templates to execute arbitrary PHP commands, leading to remote code execution and data disclosure.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-wpjx-g695-qc5j

## What is CVE-2026-44377?

CVE-2026-44377 is a critical code injection vulnerability in cubecart v6, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

CubeCart is an ecommerce software solution. Prior to 6.7.0, an Authenticated Server-Side Template Injection (SSTI) vulnerability exists in multiple modules of CubeCart (including Email Templates and Documents). The application unsafely evaluates user-supplied input directly through the Smarty template engine. By leveraging this, an authenticated attacker with administrative privileges can bypass current restrictions and call native PHP functions within the templates, such as readgzfile() to read sensitive configuration files, or error_log() to write a malicious PHP web shell, ultimately achieving Information Disclosure and full Remote Code Execution (RCE). This vulnerability is fixed in 6.7.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-44377?


## How do I fix CVE-2026-44377?

No fix has been published for CVE-2026-44377 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44377 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44377 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44377 and fix it if it is affected.

What it is: CVE-2026-44377 is a critical code injection vulnerability in cubecart v6, published on 13 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44377 exists.

Affected product: cubecart v6. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44377/ (Markdown: https://insights.sbomify.com/CVE-2026-44377/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44377
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44377
- OSV: https://osv.dev/vulnerability/CVE-2026-44377

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44377/
Summaries are generated and may contain mistakes; the official description above is the record.
