# CVE-2026-44437: Angular SSR: Open Redirect and Request Steering via Encoded X-Forwarded-Prefix

> Attackers can bypass security filters via encoded path traversal in X-Forwarded-Prefix headers, enabling open redirects and request steering in Angular SSR applications.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-69xr-m8h6-h664

## What is CVE-2026-44437?

CVE-2026-44437 is a medium-severity vulnerability in angular-cli, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Angular SSR is a server-rise rendering tool for Angular applications. From 19.0.0-next.0 to before 19.2.25, 20.3.25, 21.2.9, and 22.0.0-next.7, a vulnerability exists in the X-Forwarded-Prefix header processing logic within Angular SSR. The internal validation mechanism fails to properly account for URL-encoded characters, specifically dots (%2e%2e). This allows an attacker to bypass security filters by injecting encoded path traversal sequences that are later decoded and utilized by the application logic.
When an Angular SSR application is configured to trust proxy headers and is deployed behind a proxy that forwards the X-Forwarded-Prefix header without prior sanitization, an attacker can provide a payload such as /%2e%2e/evil. This vulnerability is fixed in19.2.25, 20.3.25, 21.2.9, and 22.0.0-next.7.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-44437?

8 open source packages ship an affected version, including @angular/ssr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/ssr` | npm | From 19.0.0-next.0 | 19.2.25 |
| `@angular/ssr` | npm | From 19.0.0-next.0 | 19.2.25 |
| `@angular/ssr` | npm | From 20.0.0-next.0 | 20.3.25 |
| `@angular/ssr` | npm | From 20.0.0-next.0 | 20.3.25 |
| `@angular/ssr` | npm | From 21.0.0-next.0 | 21.2.9 |
| `@angular/ssr` | npm | From 21.0.0-next.0 | 21.2.9 |
| `@angular/ssr` | npm | From 22.0.0-next.0 | 22.0.0-next.7 |
| `@angular/ssr` | npm | From 22.0.0-next.0 | 22.0.0-next.7 |

Products: Angular Angular Cli.

## How do I fix CVE-2026-44437?

Upgrade @angular/ssr to a fixed version for your release line: 19.2.25, 20.3.25, 21.2.9 or 22.0.0-next.7.

## Is CVE-2026-44437 being exploited?

There is no known exploitation of CVE-2026-44437 in the wild and no public exploit code.

## Other vulnerabilities in angular-cli

- [CVE-2026-32635](https://insights.sbomify.com/CVE-2026-32635/): Angular has XSS in i18n attribute bindings (high 8.6)
- [CVE-2026-33397](https://insights.sbomify.com/CVE-2026-33397/): Angular SSR Vulnerable to Protocol-Relative URL Injection via Single Backslash Bypass (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44437 and fix it if it is affected.

What it is: CVE-2026-44437 is a medium-severity vulnerability in angular-cli, published on 13 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44437 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/ssr (npm): affected from 19.0.0-next.0; fixed in 19.2.25
- @angular/ssr (npm): affected from 19.0.0-next.0; fixed in 19.2.25
- @angular/ssr (npm): affected from 20.0.0-next.0; fixed in 20.3.25
- @angular/ssr (npm): affected from 20.0.0-next.0; fixed in 20.3.25
- @angular/ssr (npm): affected from 21.0.0-next.0; fixed in 21.2.9
- @angular/ssr (npm): affected from 21.0.0-next.0; fixed in 21.2.9
- @angular/ssr (npm): affected from 22.0.0-next.0; fixed in 22.0.0-next.7
- @angular/ssr (npm): affected from 22.0.0-next.0; fixed in 22.0.0-next.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44437/ (Markdown: https://insights.sbomify.com/CVE-2026-44437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44437
- OSV: https://osv.dev/vulnerability/CVE-2026-44437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44437/
Summaries are generated and may contain mistakes; the official description above is the record.
