# CVE-2026-44450: Lumiverse: RCE via MCP stdio argument injection

> Logged-in users can execute arbitrary OS commands on the Lumiverse server via argument injection in MCP server creation, bypassing host-header checks.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 May 2026
- **Updated:** 1 Jun 2026

## What is CVE-2026-44450?

CVE-2026-44450 is a critical command injection vulnerability in prolix-oc Lumiverse, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Lumiverse is a full-featured AI chat application. Prior to 0.9.7, the MCP server creation endpoint validates the command field against an allowlist of binary names but forwards the args array to the child process without any validation. Every binary on the allowlist accepts an inline-code execution flag (-e for node/bun, -c for python3/deno), giving any logged-in user arbitrary OS-level code execution on the Lumiverse server. The route requires only requireAuth (not requireOwner). The server binds on all interfaces (::) and the host-header rebinding check is bypassed trivially by any HTTP client that sends Host: localhost:<port> directly, making this exploitable from any machine with network access to the server port. This vulnerability is fixed in 0.9.7.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-44450?


## How do I fix CVE-2026-44450?

No fix has been published for CVE-2026-44450 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-44450 being exploited?

There is no known exploitation of CVE-2026-44450 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44450 and fix it if it is affected.

What it is: CVE-2026-44450 is a critical command injection vulnerability in prolix-oc Lumiverse, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44450 in the wild and no public exploit code.

Affected product: prolix-oc Lumiverse. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44450/ (Markdown: https://insights.sbomify.com/CVE-2026-44450/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44450
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44450
- OSV: https://osv.dev/vulnerability/CVE-2026-44450

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44450/
Summaries are generated and may contain mistakes; the official description above is the record.
