CVE-2026-44454 Coder vulnerable to workspace auto-creation via crafted URL parameters without user consent
Attackers can execute arbitrary commands in provisioned workspaces via crafted dotfiles URIs, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-44454?
CVE-2026-44454 is a high-severity command injection vulnerability in coder, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Coder allows organizations to provision remote development environments via Terraform. Prior to versions 2.29.7 and 2.30.2, the `dotfiles` registry module passed unsanitized user input to shell commands, allowing arbitrary code execution inside a provisioned workspace. Any user who supplied a crafted `dotfiles_uri` value (for example, one containing shell command substitution such as `$(...)`) could achieve command execution in their own workspace. The Create Workspace page's `mode=auto` deep links amplified this into a one-click attack: an attacker could craft a URL that prefilled `param.dotfiles_uri` and silently provisioned a workspace with the attacker-controlled value, with no explicit user confirmation. In versions 2.29.7 and 2.30.2, input validation was added to the dotfiles module to reject URIs and usernames containing special characters, and the unsafe `eval`/`sh -c` usage was removed. This eliminated the command injection at its source.
Weakness: CWE-78
Which versions are affected by CVE-2026-44454?
8 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/coder/coder/v2 Go | All versions | 2.29.7, 2.30.2 |
github.com/coder/coder/v2 Go | All versions | 2.29.7 |
github.com/coder/coder/v2 Go | All versions | 2.29.7 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.30.2 |
github.com/coder/coder/v2 Go | From 2.30.0 | 2.30.2 |
github.com/coder/coder Go | All versions | None |
2 more packages
github.com/coder/coder Go | All versions to 0.27.3 | None |
github.com/coder/coder Go | All versions to 0.27.3 | None |
Products include Coder Coder.
How do I fix CVE-2026-44454?
Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.29.7 or 2.30.2.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-44454 being exploited?
There is no known exploitation of CVE-2026-44454 in the wild and no public exploit code.
Other vulnerabilities in coder
- CVE-2026-46354 Coder: PKCS#7 signature bypass in Azure instance identity allows unauthenticated agent token theft
- CVE-2026-55429 Coder's workspace app upsert allows cross-workspace agent rebinding via user-controlled app ID
- CVE-2026-55427 Coder vulnerable to SSH config injection via unsanitized server-supplied values in `coder config-ssh`
- CVE-2026-55428 Coder: Route hijacking through lack of validation of agent-supplied AllowedIPs in tailnet coordinator
- CVE-2024-27918 Coder's OIDC authentication allows email with partially matching domain to register
Sources
Also known as GHSA-m3cr-vc2j-pm27, GO-2026-5897.