# CVE-2026-44475: Ella Core: UE Security Capability bypass on NGAP PathSwitchRequest

> A malicious gNB can bypass security checks by overwriting UE security capabilities in Ella Core via crafted PathSwitchRequest messages.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-pwfh-mqp3-pqwj, GO-2026-5554

## What is CVE-2026-44475?

CVE-2026-44475 is a medium-severity missing authorization vulnerability in ellanetworks core, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Ella Core is a 5G core designed for private networks. Prior to 1.10.0, Ella Core does not verify the UE Security Capabilities received in NGAP PathSwitchRequest messages against its locally stored values. A malicious gNB can overwrite Ella Core's stored UE security capabilities for any UE with arbitrary values by sending a single crafted PathSwitchRequest. This vulnerability is fixed in 1.10.0.

Weakness: CWE-358 (Improperly Implemented Security Check for Standard)

## Which versions are affected by CVE-2026-44475?

3 open source packages ship an affected version, including github.com/ellanetworks/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ellanetworks/core` | Go | All versions | 1.10.0 |
| `github.com/ellanetworks/core` | Go | All versions | 1.10.0 |
| `github.com/ellanetworks/core` | Go | All versions | 1.10.0 |

## How do I fix CVE-2026-44475?

Upgrade github.com/ellanetworks/core to 1.10.0 or later.

## Is CVE-2026-44475 being exploited?

There is no known exploitation of CVE-2026-44475 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44475 and fix it if it is affected.

What it is: CVE-2026-44475 is a medium-severity missing authorization vulnerability in ellanetworks core, published on 27 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44475 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ellanetworks/core (Go): affected all versions; fixed in 1.10.0
- github.com/ellanetworks/core (Go): affected all versions; fixed in 1.10.0
- github.com/ellanetworks/core (Go): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44475/ (Markdown: https://insights.sbomify.com/CVE-2026-44475/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44475
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44475
- OSV: https://osv.dev/vulnerability/CVE-2026-44475

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44475/
Summaries are generated and may contain mistakes; the official description above is the record.
