# CVE-2026-44484: Compromise of PyTorch Lightning PyPi Package Versions

> Attackers can harvest credentials via malicious code in compromised PyTorch Lightning PyPI packages, affecting AI developers using the library.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-w37p-236h-pfx3, PYSEC-2026-3973, PYSEC-2026-508

## What is CVE-2026-44484?

CVE-2026-44484 is a critical vulnerability in Lightning-AI pytorch-lightning, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyTorch Lightning is a deep learning framework to pretrain and finetune AI models. Versions 2.6.2 and 2.6.2 have introduced functionality consistent with a credential harvesting mechanism.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere), CWE-506 (Embedded Malicious Code)

## Which versions are affected by CVE-2026-44484?

4 open source packages ship an affected version, including pytorch-lightning and lightning. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch-lightning` | PyPI | All versions | None |
| `pytorch-lightning` | PyPI | All versions | None |
| `pytorch-lightning` | PyPI | From 2.6.2 | 2.6.4 |
| `lightning` | PyPI | From 2.6.2 | 2.6.4 |

Products: Lightningai Pytorch Lightning.

## How do I fix CVE-2026-44484?

Upgrade pytorch-lightning to 2.6.4 or later.

## Is CVE-2026-44484 being exploited?

There is no known exploitation of CVE-2026-44484 in the wild and no public exploit code.

## Other vulnerabilities in Lightning-AI pytorch-lightning

- [CVE-2024-5452](https://insights.sbomify.com/CVE-2024-5452/): RCE via Property/Class Pollution in lightning-ai/pytorch-lightning (critical 9.8)
- [CVE-2024-8019](https://insights.sbomify.com/CVE-2024-8019/): Arbitrary File Write/Overwrite in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2024-5980](https://insights.sbomify.com/CVE-2024-5980/): Arbitrary File Write via /v1/runs API endpoint in lightning-ai/pytorch-lightning (critical 9.1)
- [CVE-2026-31221](https://insights.sbomify.com/CVE-2026-31221/): PyTorch Lightning load_from_checkpoint has an insecure checkpoint deserialization (high 8.8)
- [CVE-2026-58659](https://insights.sbomify.com/CVE-2026-58659/): PyTorch Lightning Arbitrary Code Execution via _instantiator Hyperparameter (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44484 and fix it if it is affected.

What it is: CVE-2026-44484 is a critical vulnerability in Lightning-AI pytorch-lightning, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44484 in the wild and no public exploit code.

Affected packages and fixed versions:
- pytorch-lightning (PyPI): affected all versions; no fix listed
- pytorch-lightning (PyPI): affected all versions; no fix listed
- pytorch-lightning (PyPI): affected from 2.6.2; fixed in 2.6.4
- lightning (PyPI): affected from 2.6.2; fixed in 2.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44484/ (Markdown: https://insights.sbomify.com/CVE-2026-44484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44484
- OSV: https://osv.dev/vulnerability/CVE-2026-44484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44484/
Summaries are generated and may contain mistakes; the official description above is the record.
