# CVE-2026-44489: Axios: Proxy-Authorization Header Injection via Prototype Pollution — Incomplete Null-Prototype Fix

> Prototype pollution allows injecting attacker-controlled Proxy-Authorization headers into proxied requests, potentially exposing credentials or bypassing authentication.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-44489, ECHO-e2b7-45f0-bb81, GHSA-654m-c8p4-x5fp, MINI-4mj2-5rpf-rccx, MINI-7w7m-99h4-g3mh, MINI-9xj4-58p8-hgvm, MINI-cgjw-w43w-fqvm, MINI-crpr-wvmj-mcv9, MINI-g65c-4mpx-4736, MINI-h5r4-53rr-x6x4, MINI-jc7f-jxjr-55m7, ROOT-APP-NPM-CVE-2026-44489, UBUNTU-CVE-2026-44489

## What is CVE-2026-44489?

CVE-2026-44489 is a low-severity code injection vulnerability in axios, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. From 1.15.2 to before 1.16.0, nested objects created by utils.merge() (e.g., config.proxy) are still constructed as plain {} with Object.prototype in their chain. The setProxy() function at lib/adapters/http.js:209-223 reads proxy.username, proxy.password, and proxy.auth without hasOwnProperty checks. When Object.prototype.username is polluted, setProxy() constructs a Proxy-Authorization header with attacker-controlled credentials and injects it into every proxied HTTP request. This vulnerability is fixed in 1.16.0.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-44489?

2 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 1.15.2 | 1.16.0 |
| `axios` | npm | From 1.15.2 | 1.16.0 |

Products: Axios Axios.

## How do I fix CVE-2026-44489?

Upgrade axios to 1.16.0 or later.

## Is CVE-2026-44489 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44489 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44489 and fix it if it is affected.

What it is: CVE-2026-44489 is a low-severity code injection vulnerability in axios, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44489 exists.

Affected packages and fixed versions:
- axios (npm): affected from 1.15.2; fixed in 1.16.0
- axios (npm): affected from 1.15.2; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44489/ (Markdown: https://insights.sbomify.com/CVE-2026-44489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44489
- OSV: https://osv.dev/vulnerability/CVE-2026-44489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44489/
Summaries are generated and may contain mistakes; the official description above is the record.
