# CVE-2026-44492: axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718)

> Attackers can bypass NO_PROXY restrictions using IPv4-mapped IPv6 addresses to access internal services via a proxy, potentially leading to SSRF.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Sep 2026
- **Also known as:** CLEANSTART-2026-CX76306, CLSA-2026-1793101250, DEBIAN-CVE-2026-44492, ECHO-5ca0-ec34-e518, GHSA-pjwm-pj3p-43mv, MINI-2435-qg94-mhrx, MINI-25xv-x43w-cvxr, MINI-2939-v94c-h897, MINI-3hmg-5g6m-w5mm, MINI-3pf5-j66h-xccx, MINI-4hch-v9r5-hhmj, MINI-56jm-rxp3-mwq2, MINI-729v-j659-46jv, MINI-78qw-g7p8-34p5, MINI-8hp2-qfpf-w4fg, MINI-987c-c399-xg2c, MINI-c47v-5gpr-gw7c, MINI-cxmj-6cw9-gj6c, MINI-fxm5-gx3m-4cr2, MINI-jfj7-9m2c-fcqq, MINI-mhx3-m78g-4hv7, MINI-mj6x-fjvx-62pg, MINI-q6p2-r67p-r8px, MINI-q94r-4v67-qc8f, MINI-qh7w-5xx7-fcr7, MINI-rqfg-w5pf-g7f2, MINI-v623-q4fc-8qvj, MINI-vjqg-5w5f-wm2v, MINI-w3mv-jcjw-v396, MINI-wjhp-gfx7-2gr9, ROOT-APP-NPM-CVE-2026-44492, UBUNTU-CVE-2026-44492

## What is CVE-2026-44492?

CVE-2026-44492 is a high-severity server-side request forgery vulnerability in axios, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Prior to 0.32.0 and 1.16.0, Axios does not normalise IPv4-mapped IPv6 addresses. When NO_PROXY lists an IPv4 address such as 127.0.0.1 or 169.254.169.254, a request URL using the IPv4-mapped IPv6 form (::ffff:7f00:1, ::ffff:a9fe:a9fe) still routes through the configured proxy. Node.js resolves these addresses to the underlying IPv4 host, so the request reaches the internal service via the proxy rather than being blocked. This vulnerability is fixed in 0.32.0 and 1.16.0.

Weakness: CWE-289 (Authentication Bypass by Alternate Name), CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44492?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.32.0 |
| `axios` | npm | All versions | 0.32.0 |
| `axios` | npm | From 1.15.0 | 1.16.0 |
| `axios` | npm | From 1.15.0 | 1.16.0 |

Products: Axios Axios.

## How do I fix CVE-2026-44492?

Upgrade axios to a fixed version for your release line: 0.32.0 or 1.16.0.

## Is CVE-2026-44492 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44492 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)
- [CVE-2026-44486](https://insights.sbomify.com/CVE-2026-44486/): Axios: Proxy-Authorization header leaks to redirect target when proxy is re-evaluated to direct connection (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44492 and fix it if it is affected.

What it is: CVE-2026-44492 is a high-severity server-side request forgery vulnerability in axios, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44492 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.32.0
- axios (npm): affected all versions; fixed in 0.32.0
- axios (npm): affected from 1.15.0; fixed in 1.16.0
- axios (npm): affected from 1.15.0; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44492/ (Markdown: https://insights.sbomify.com/CVE-2026-44492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44492
- OSV: https://osv.dev/vulnerability/CVE-2026-44492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44492/
Summaries are generated and may contain mistakes; the official description above is the record.
