# CVE-2026-44496: Axios: Regular Expression Denial of Service (ReDoS) via Cookie Name Injection

> An attacker can cause browser tab freezing in Axios by injecting regex metacharacters into the XSRF cookie name, leading to client-side denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Sep 2026
- **Also known as:** CLEANSTART-2026-UY90963, CLSA-2026-1785117458, CLSA-2026-1793180826, DEBIAN-CVE-2026-44496, ECHO-2e2e-8d9d-ff19, GHSA-hfxv-24rg-xrqf, MINI-296g-f8f2-cqv6, MINI-3xf9-46gg-6259, MINI-4jw7-5336-3hw7, MINI-5j3x-j4mf-2vfj, MINI-5rm2-p2v8-2j6f, MINI-6f87-rrj5-pcxj, MINI-7qvm-9xrv-cmp8, MINI-985x-wp5h-4rjp, MINI-c2j4-grmm-f8fj, MINI-cc9h-9c47-xw74, MINI-cpf2-pw2x-p99j, MINI-fpgp-369g-897c, MINI-jj9v-r6j7-q7wg, MINI-m852-g67v-25wg, MINI-qqq8-24m8-xgwf, MINI-qv5q-g8xw-w3wr, MINI-r75p-f9j7-pr2p, MINI-vf9v-8g5c-6547, MINI-vmcp-hfw6-hgv5, MINI-w3c6-pf74-m27f, MINI-w55g-qr7h-fjfj, MINI-w5xm-5gcv-9f58, MINI-x8vf-5g5f-jvg6, MINI-xv2q-22rj-m82m, MINI-xwfm-q7gq-gx8g, ROOT-APP-NPM-CVE-2026-44496, UBUNTU-CVE-2026-44496

## What is CVE-2026-44496?

CVE-2026-44496 is a high-severity denial of service vulnerability in axios, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise based HTTP client for the browser and Node.js. Axios versions before 0.32.0 on the 0.x line and before 1.16.0 on the 1.x line build a regular expression from the configured XSRF cookie name without escaping regex metacharacters. In standard browser environments, an attacker who can influence the cookie name passed to axios can cause expensive regex backtracking while axios reads document.cookie. The practical impact is client-side availability degradation, such as freezing the affected browser tab while axios prepares a request. The issue does not affect ordinary Node.js HTTP adapter usage, React Native, or web workers, where axios does not read document.cookie. This vulnerability is fixed in 0.32.0 and 1.16.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-44496?

4 open source packages ship an affected version, including axios. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | All versions | 0.32.0 |
| `axios` | npm | All versions | 0.32.0 |
| `axios` | npm | From 1.0.0 | 1.16.0 |
| `axios` | npm | From 1.0.0 | 1.16.0 |

Products: Axios Axios.

## How do I fix CVE-2026-44496?

Upgrade axios to a fixed version for your release line: 0.32.0 or 1.16.0.

## Is CVE-2026-44496 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44496 exists.

## Other vulnerabilities in axios

- [CVE-2026-44494](https://insights.sbomify.com/CVE-2026-44494/): Axios: Full Man-in-the-Middle via Prototype Pollution Gadget in `config.proxy` (high 8.7)
- [CVE-2026-44492](https://insights.sbomify.com/CVE-2026-44492/): axios's shouldBypassProxy does not recognize IPv4-mapped IPv6 addresses, allowing NO_PROXY bypass (incomplete fix for CVE-2025-62718) (high 8.6)
- [CVE-2026-67320](https://insights.sbomify.com/CVE-2026-67320/): axios before 0.33.0 Prototype Pollution via Node HTTP adapter (high 8.3)
- [CVE-2026-44487](https://insights.sbomify.com/CVE-2026-44487/): Axios: Proxy-Authorization Credential Leak to Origin Server Across HTTP-to-HTTPS Redirect in Axios Node.js HTTP Adapter (high 8.2)
- [CVE-2025-27152](https://insights.sbomify.com/CVE-2025-27152/): Possible SSRF and Credential Leakage via Absolute URL in axios Requests (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44496 and fix it if it is affected.

What it is: CVE-2026-44496 is a high-severity denial of service vulnerability in axios, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-44496 exists.

Affected packages and fixed versions:
- axios (npm): affected all versions; fixed in 0.32.0
- axios (npm): affected all versions; fixed in 0.32.0
- axios (npm): affected from 1.0.0; fixed in 1.16.0
- axios (npm): affected from 1.0.0; fixed in 1.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44496/ (Markdown: https://insights.sbomify.com/CVE-2026-44496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44496
- OSV: https://osv.dev/vulnerability/CVE-2026-44496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44496/
Summaries are generated and may contain mistakes; the official description above is the record.
