# CVE-2026-44502: Bugsink: SSRF bypass in `validate_webhook_url`

> Attackers can bypass webhook URL validation to access internal resources via SSRF in Bugsink error tracking tool.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 27 May 2026
- **Also known as:** GHSA-fp53-qcf8-2xx2, PYSEC-2026-2405

## What is CVE-2026-44502?

CVE-2026-44502 is a medium-severity server-side request forgery vulnerability in bugsink, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Bugsink is a self-hosted error tracking tool. Prior to 2.1.3, Bugsink’s webhook URL validation could be (partially) bypassed because of a mismatch in URL parsing. The original validation logic parsed webhook URLs with Python’s urllib.parse.urlparse, then sent the request with requests.post. For malformed inputs involving backslashes and @, those components can disagree about where the authority ends and which hostname is the real target. A URL may therefore appear to target an allowlisted public hostname during validation, while the HTTP client actually connects to a different host. This vulnerability is fixed in 2.1.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-44502?

3 open source packages ship an affected version, including bugsink.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bugsink` | PyPI | All versions | 2.1.3 |
| `bugsink` | PyPI | All versions | 2.1.3 |
| `bugsink` | PyPI | All versions | 2.1.3 |

## How do I fix CVE-2026-44502?

Upgrade bugsink to 2.1.3 or later.

## Is CVE-2026-44502 being exploited?

There is no known exploitation of CVE-2026-44502 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44502 and fix it if it is affected.

What it is: CVE-2026-44502 is a medium-severity server-side request forgery vulnerability in bugsink, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44502 in the wild and no public exploit code.

Affected packages and fixed versions:
- bugsink (PyPI): affected all versions; fixed in 2.1.3
- bugsink (PyPI): affected all versions; fixed in 2.1.3
- bugsink (PyPI): affected all versions; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44502/ (Markdown: https://insights.sbomify.com/CVE-2026-44502/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44502
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44502
- OSV: https://osv.dev/vulnerability/CVE-2026-44502

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44502/
Summaries are generated and may contain mistakes; the official description above is the record.
