{"answers":{"affected":"3 open source packages ship an affected version, including aegra-api.","exploited":"There is no known exploitation of CVE-2026-44504 in the wild and no public exploit code.","fix":"Upgrade aegra-api to 0.9.7 or later.","what":"CVE-2026-44504 is a high-severity missing authorization vulnerability in aegra, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-44504 and fix it if it is affected.\n\nWhat it is: CVE-2026-44504 is a high-severity missing authorization vulnerability in aegra, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-44504 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aegra-api (PyPI): affected from 0.9.0; fixed in 0.9.7\n- aegra-api (PyPI): affected from 0.9.0; fixed in 0.9.7\n- aegra-api (PyPI): affected from 0.9.0; fixed in 0.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-44504/ (Markdown: https://insights.sbomify.com/CVE-2026-44504/index.md)","id":"CVE-2026-44504","markdown":"https://insights.sbomify.com/CVE-2026-44504/index.md","name":"CVE-2026-44504","record":{"aliases":["GHSA-m98r-6667-4wq7","PYSEC-2026-2328"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI deployment library","requires_auth":"low_privilege","summary":"Authenticated attackers can access and modify other users' AI conversation threads and state by exploiting missing authorization checks in the Aegra library.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-639","name":"Authorization Bypass Through User-Controlled Key"},{"id":"CWE-285","name":"Improper Authorization"}],"description":"Aegra is a drop-in replacement for LangSmith Deployments. Prior to 0.9.7, with multiple authenticated users on a shared instance are vulnerable to a cross-tenant IDOR. Any authenticated attacker, given another user's thread_id, can execute graph runs against the user's thread, read the user's full checkpoint state, and inject arbitrary messages into the user's conversation history. This vulnerability is fixed in 0.9.7.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Aegra: Cross-user run injection in /threads/{thread_id}/runs (IDOR)","id":"CVE-2026-44504","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Nimiq network-libp2p: Untrusted peer can wedge DHT","id":"CVE-2026-44505"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.7"],"introduced":["0.9.0"],"last_affected":[],"package":"aegra-api","purl":null,"source":"GHSA-m98r-6667-4wq7"},{"ecosystem":"PyPI","fixed":["0.9.7"],"introduced":["0.9.0"],"last_affected":[],"package":"aegra-api","purl":"pkg:pypi/aegra-api","source":"GHSA-m98r-6667-4wq7"},{"ecosystem":"PyPI","fixed":["0.9.7"],"introduced":["0.9.0"],"last_affected":[],"package":"aegra-api","purl":"pkg:pypi/aegra-api","source":"PYSEC-2026-2328"}],"prev":{"headline":"Kiota abstractions RedirectHandler leaks Cookie/Proxy-Authorization headers on cross-host redirect","id":"CVE-2026-44503"},"products":["aegra"],"published":"2026-05-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-16","vendors":["aegra"]},"summary":"Authenticated attackers can access and modify other users' AI conversation threads and state by exploiting missing authorization checks in the Aegra library.","url":"https://insights.sbomify.com/CVE-2026-44504/"}