# CVE-2026-44504: Aegra: Cross-user run injection in /threads/{thread_id}/runs (IDOR)

> Authenticated attackers can access and modify other users' AI conversation threads and state by exploiting missing authorization checks in the Aegra library.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 16 May 2026
- **Also known as:** GHSA-m98r-6667-4wq7, PYSEC-2026-2328

## What is CVE-2026-44504?

CVE-2026-44504 is a high-severity missing authorization vulnerability in aegra, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Aegra is a drop-in replacement for LangSmith Deployments. Prior to 0.9.7, with multiple authenticated users on a shared instance are vulnerable to a cross-tenant IDOR. Any authenticated attacker, given another user's thread_id, can execute graph runs against the user's thread, read the user's full checkpoint state, and inject arbitrary messages into the user's conversation history. This vulnerability is fixed in 0.9.7.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-44504?

3 open source packages ship an affected version, including aegra-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aegra-api` | PyPI | From 0.9.0 | 0.9.7 |
| `aegra-api` | PyPI | From 0.9.0 | 0.9.7 |
| `aegra-api` | PyPI | From 0.9.0 | 0.9.7 |

## How do I fix CVE-2026-44504?

Upgrade aegra-api to 0.9.7 or later.

## Is CVE-2026-44504 being exploited?

There is no known exploitation of CVE-2026-44504 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-44504 and fix it if it is affected.

What it is: CVE-2026-44504 is a high-severity missing authorization vulnerability in aegra, published on 14 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-44504 in the wild and no public exploit code.

Affected packages and fixed versions:
- aegra-api (PyPI): affected from 0.9.0; fixed in 0.9.7
- aegra-api (PyPI): affected from 0.9.0; fixed in 0.9.7
- aegra-api (PyPI): affected from 0.9.0; fixed in 0.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-44504/ (Markdown: https://insights.sbomify.com/CVE-2026-44504/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-44504
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-44504
- OSV: https://osv.dev/vulnerability/CVE-2026-44504

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-44504/
Summaries are generated and may contain mistakes; the official description above is the record.
